aboutsummarylogtreecommitdiffstats
path: root/kpartx_install
diff options
context:
space:
mode:
authorUlrich Ölmann2022-12-18 16:17:24 +0100
committerUlrich Ölmann2022-12-18 18:30:47 +0100
commit79359734b9475abbbf18d34e36dc8f8d9c28fbb2 (patch)
tree974a8986365925321daa39966039078eeaaf47e3 /kpartx_install
downloadaur-79359734b9475abbbf18d34e36dc8f8d9c28fbb2.tar.gz
add initial package and resulting .SRCINFO
The latter has been created via makepkg --printsrcinfo > .SRCINFO and needs to be recreated most of the times when PKGBUILD is adjusted. Signed-off-by: Ulrich Ölmann <ulrich.oelmann@web.de>
Diffstat (limited to 'kpartx_install')
-rw-r--r--kpartx_install20
1 files changed, 20 insertions, 0 deletions
diff --git a/kpartx_install b/kpartx_install
new file mode 100644
index 000000000000..7f977c9506aa
--- /dev/null
+++ b/kpartx_install
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+build() {
+ add_binary 'kpartx'
+
+ add_runscript
+}
+
+help() {
+ cat <<HELPEOF
+If your decrypted device is not structured via LVM2, but has a GPT instead (to
+save one level of indirection), its contained partitions do not show up as block
+devices without further help. Unfortunately, tools like 'partprobe' or 'partx'
+fail to establish those subdevices. Hence, a different approach has to be
+followed by utilization of 'kpartx' from the 'multipath-tools' package which is
+what this hook does. Just put this hook directly after the 'encrypt' hook.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et: