summarylogtreecommitdiffstats
path: root/l-qclipboard_delay.patch
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-02-18 11:23:49 -0800
committerLlewelyn Trahaearn2017-02-18 11:23:49 -0800
commitbef4f7fb2f5bbbeb5da6959c5757cd108db51996 (patch)
treeb4778f34e36bce66c7afa554243f3c806be13063 /l-qclipboard_delay.patch
parent77e07c49a2e24c4d64fa1b25fb54c123a7367136 (diff)
downloadaur-bef4f7fb2f5bbbeb5da6959c5757cd108db51996.tar.gz
Adopted, rebased on PKGBUILD from [Extra]. Clang no longer used.
Diffstat (limited to 'l-qclipboard_delay.patch')
-rw-r--r--l-qclipboard_delay.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/l-qclipboard_delay.patch b/l-qclipboard_delay.patch
new file mode 100644
index 000000000000..22643e8d5a01
--- /dev/null
+++ b/l-qclipboard_delay.patch
@@ -0,0 +1,12 @@
+--- src/gui/kernel/qclipboard_x11.cpp.sav 2014-04-25 09:52:03.855693228 +0200
++++ src/gui/kernel/qclipboard_x11.cpp 2014-04-25 09:51:58.038693777 +0200
+@@ -548,7 +548,8 @@ bool QX11Data::clipboardWaitForEvent(Win
+ return false;
+
+ XSync(X11->display, false);
+- usleep(50000);
++ if (!XPending(X11->display))
++ usleep(5000);
+
+ now.start();
+