summarylogtreecommitdiffstats
path: root/libqxt-gcc6.patch
diff options
context:
space:
mode:
authorManuel Hüsers2016-05-11 16:12:22 +0200
committerManuel Hüsers2016-05-11 16:12:22 +0200
commit9acaff7ead832bf2015b7464fb9f574857e21d6b (patch)
tree01ab31de5efd5716211735b98628f2fb359b6ece /libqxt-gcc6.patch
parentd4fd25eff32ed3dc513c9e4ead6201d68af4752a (diff)
downloadaur-9acaff7ead832bf2015b7464fb9f574857e21d6b.tar.gz
Fix build error and refactor PKGBUILD
Diffstat (limited to 'libqxt-gcc6.patch')
-rw-r--r--libqxt-gcc6.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/libqxt-gcc6.patch b/libqxt-gcc6.patch
new file mode 100644
index 000000000000..519646d6eb6d
--- /dev/null
+++ b/libqxt-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/src/core/qxtslotjob.cpp 2011-11-24 16:10:32.000000000 -0600
++++ b/src/core/qxtslotjob.cpp 2016-03-07 16:20:32.758268253 -0600
+@@ -174,7 +174,7 @@ This uses QxtSignalWaiter so it will _no
+
+ QVariant QxtFuture::delayedResult(int msec)
+ {
+- if (!waiter->wait(msec, false))
++ if (!waiter->wait(msec, NULL))
+ return QVariant();
+ return job->result();
+ }