summarylogtreecommitdiffstats
path: root/libtirpc.patch
diff options
context:
space:
mode:
authorPeter Ivanov2018-11-07 19:00:45 +0100
committerPeter Ivanov2018-11-07 19:00:45 +0100
commit0cdce947825a88c7e300b4c2e32b56c5f4dac709 (patch)
treef1a6d96364e044997c55e4de387c0b301649d381 /libtirpc.patch
parent61c48342399eb42d4d4164b52b3396e8f60c2912 (diff)
downloadaur-0cdce947825a88c7e300b4c2e32b56c5f4dac709.tar.gz
It can be compiled again.
Diffstat (limited to 'libtirpc.patch')
-rw-r--r--libtirpc.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/libtirpc.patch b/libtirpc.patch
new file mode 100644
index 000000000000..58f1fa1c0486
--- /dev/null
+++ b/libtirpc.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile b/src/Makefile
+index a99e52686..9b2b5705e 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -139,7 +139,7 @@ ULAPISRCS := rtapi/$(RTPREFIX)_ulapi.c
+
+ # Each item in INCLUDES is transformed into a -I directive later on
+ # The top directory is always included
+-INCLUDES := .
++INCLUDES := . /usr/include/tirpc/
+
+ USERSRCS :=
+ PROGRAMS :=
+@@ -203,6 +203,8 @@ else
+ LDFLAGS := -Wl,-rpath-link,../lib
+ endif
+
++LDFLAGS += -ltirpc
++
+ # Rules to make .o (object) files
+ $(sort $(CUSEROBJS)) : objects/%.o: %.c
+ $(ECHO) Compiling $<