summarylogtreecommitdiffstats
path: root/libxcrypt.patch
diff options
context:
space:
mode:
authorBryan Horna2020-12-27 03:44:40 -0500
committerBryan Horna2020-12-27 03:44:40 -0500
commit116ea70dcfc9bc6ac1aca379f23c1c61acf9552a (patch)
tree9ec6647f0614fca59ad3ea1574baf7602ee0c5b3 /libxcrypt.patch
parentb2bd33ef6a7c507524f4526d2496d4cc1432c41c (diff)
downloadaur-116ea70dcfc9bc6ac1aca379f23c1c61acf9552a.tar.gz
Bring back multiarch support
Diffstat (limited to 'libxcrypt.patch')
-rw-r--r--libxcrypt.patch23
1 files changed, 14 insertions, 9 deletions
diff --git a/libxcrypt.patch b/libxcrypt.patch
index 1834bb4d5902..6cb51b5d81bc 100644
--- a/libxcrypt.patch
+++ b/libxcrypt.patch
@@ -1,23 +1,28 @@
-diff --unified --recursive --text --color asleap-2.2/Makefile asleap-2.2-new/Makefile
+diff -Naur asleap-2.2/Makefile asleap-2.2-new/Makefile
--- asleap-2.2/Makefile 2007-07-13 20:00:58.000000000 -0500
-+++ asleap-2.2-new/Makefile 2020-12-19 21:38:02.071555347 -0500
-@@ -7,10 +7,12 @@
++++ asleap-2.2-new/Makefile 2020-12-27 03:33:49.819887649 -0500
+@@ -6,12 +6,14 @@
+ # <dragorn> heh
# <dragorn> i think thats all anyone does
# <dragorn> make is a twisted beast
++# <bryanjhv> pull https://github.com/joswr1ght/asleap/commit/4576d14
##################################
-LDLIBS = -lpcap -lcrypt
+-CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
+-CFLAGS += -D_OPENSSL_MD4
+LDLIBS = -lpcap -lxcrypt
- CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
- CFLAGS += -D_OPENSSL_MD4
++CFLAGS = -pipe -Wall -D_LINUX -D_OPENSSL_MD4
LDLIBS += -lcrypto
-+LDLIBS += -L"../deb/usr/lib"
+-CFLAGS += -g3 -ggdb -g
++CFLAGS += -g3 #-ggdb -g
++LDLIBS += -L"../deb/lib"
+CFLAGS += -I"../deb/usr/include"
- CFLAGS += -g3 -ggdb -g
PROGOBJ = asleap.o genkeys.o utils.o common.o sha1.o
PROG = asleap genkeys
-diff --unified --recursive --text --color asleap-2.2/utils.c asleap-2.2-new/utils.c
+
+diff -Naur asleap-2.2/utils.c asleap-2.2-new/utils.c
--- asleap-2.2/utils.c 2007-07-13 20:00:58.000000000 -0500
-+++ asleap-2.2-new/utils.c 2020-12-19 21:30:14.418336923 -0500
++++ asleap-2.2-new/utils.c 2020-12-27 03:26:18.439970818 -0500
@@ -27,7 +27,7 @@
#include <stdarg.h>
#include <string.h>