summarylogtreecommitdiffstats
path: root/libxcrypt.patch
diff options
context:
space:
mode:
authorBryan Horna2020-12-19 22:10:25 -0500
committerBryan Horna2020-12-19 22:10:25 -0500
commit5f8fcfea70b6622bc516b486132d6bb84409144f (patch)
treeb85d0372a9aa1205a106c58f7a7f2e5ec80cdd31 /libxcrypt.patch
parent06a5b8a8e4f01edbbcbc79c5e83f6b716deabbd0 (diff)
downloadaur-5f8fcfea70b6622bc516b486132d6bb84409144f.tar.gz
Fix build by adding missing dependencies
Diffstat (limited to 'libxcrypt.patch')
-rw-r--r--libxcrypt.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/libxcrypt.patch b/libxcrypt.patch
new file mode 100644
index 000000000000..1834bb4d5902
--- /dev/null
+++ b/libxcrypt.patch
@@ -0,0 +1,29 @@
+diff --unified --recursive --text --color asleap-2.2/Makefile asleap-2.2-new/Makefile
+--- asleap-2.2/Makefile 2007-07-13 20:00:58.000000000 -0500
++++ asleap-2.2-new/Makefile 2020-12-19 21:38:02.071555347 -0500
+@@ -7,10 +7,12 @@
+ # <dragorn> i think thats all anyone does
+ # <dragorn> make is a twisted beast
+ ##################################
+-LDLIBS = -lpcap -lcrypt
++LDLIBS = -lpcap -lxcrypt
+ CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
+ CFLAGS += -D_OPENSSL_MD4
+ LDLIBS += -lcrypto
++LDLIBS += -L"../deb/usr/lib"
++CFLAGS += -I"../deb/usr/include"
+ CFLAGS += -g3 -ggdb -g
+ PROGOBJ = asleap.o genkeys.o utils.o common.o sha1.o
+ PROG = asleap genkeys
+diff --unified --recursive --text --color asleap-2.2/utils.c asleap-2.2-new/utils.c
+--- asleap-2.2/utils.c 2007-07-13 20:00:58.000000000 -0500
++++ asleap-2.2-new/utils.c 2020-12-19 21:30:14.418336923 -0500
+@@ -27,7 +27,7 @@
+ #include <stdarg.h>
+ #include <string.h>
+ #include <stdint.h>
+-#include <crypt.h>
++#include <xcrypt.h>
+ #include <unistd.h>
+ #include <ctype.h>
+ #include <netinet/in.h> /* for ntohs() */