summarylogtreecommitdiffstats
path: root/line_profiler.patch
diff options
context:
space:
mode:
authorMichael Klimczak2018-09-30 17:40:46 +0200
committerMichael Klimczak2018-09-30 17:40:46 +0200
commit4f3c4c2033e8cfe3438bda18f01586ba983af918 (patch)
treec8fdca3065e08fa6145b5d1f62e9aa20045ab9a6 /line_profiler.patch
parentabbabd4bb4fb7454d9d94e680da0144156ff0261 (diff)
downloadaur-4f3c4c2033e8cfe3438bda18f01586ba983af918.tar.gz
added patch and modified PKGBUILD to fix issues with python 3.7
Diffstat (limited to 'line_profiler.patch')
-rw-r--r--line_profiler.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/line_profiler.patch b/line_profiler.patch
new file mode 100644
index 000000000000..803c7579bdd7
--- /dev/null
+++ b/line_profiler.patch
@@ -0,0 +1,24 @@
+diff -ruN line_profiler-2.1.2.orig/kernprof.py line_profiler-2.1.2/kernprof.py
+--- line_profiler-2.1.2.orig/kernprof.py 2018-08-30 14:14:52.722665861 +0200
++++ line_profiler-2.1.2/kernprof.py 2018-08-30 14:18:42.516791010 +0200
+@@ -102,6 +102,8 @@
+ self.enable_by_count()
+ try:
+ item = g.send(input)
++ except StopIteration:
++ return
+ finally:
+ self.disable_by_count()
+ input = (yield item)
+diff -ruN line_profiler-2.1.2.orig/line_profiler.py line_profiler-2.1.2/line_profiler.py
+--- line_profiler-2.1.2.orig/line_profiler.py 2018-08-30 14:14:52.722665861 +0200
++++ line_profiler-2.1.2/line_profiler.py 2018-08-30 14:19:11.210222041 +0200
+@@ -100,6 +100,8 @@
+ self.enable_by_count()
+ try:
+ item = g.send(input)
++ except StopIteration:
++ return
+ finally:
+ self.disable_by_count()
+ input = (yield item)