summarylogtreecommitdiffstats
path: root/linphone.patch
diff options
context:
space:
mode:
authorfrealgagu2018-11-18 18:22:22 -0500
committerfrealgagu2018-11-18 18:22:22 -0500
commitb91eb17ab282adc41deda36797b9dfa92064f9bf (patch)
tree09312f708df5ae1b42d3a2640074c9edfbdf84da /linphone.patch
downloadaur-b91eb17ab282adc41deda36797b9dfa92064f9bf.tar.gz
Initial commit.
Diffstat (limited to 'linphone.patch')
-rw-r--r--linphone.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/linphone.patch b/linphone.patch
new file mode 100644
index 000000000000..474a01d0ac20
--- /dev/null
+++ b/linphone.patch
@@ -0,0 +1,24 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 02aa98e05..0f89e40aa 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,6 +23,8 @@
+ cmake_minimum_required(VERSION 3.0)
+ project(linphone VERSION 3.12.0 LANGUAGES C CXX)
+
++# Pointing RPATH to /opt/linphone-desktop/lib{,64} to be used when installing
++SET(CMAKE_INSTALL_RPATH "/opt/linphone-desktop/lib:/opt/linphone-desktop/lib64")
+
+ set(LINPHONE_MAJOR_VERSION ${PROJECT_VERSION_MAJOR})
+ set(LINPHONE_MINOR_VERSION ${PROJECT_VERSION_MINOR})
+@@ -48,8 +50,8 @@ option(ENABLE_LDAP "Enable LDAP support." NO)
+ option(ENABLE_SQLITE_STORAGE "Turn on compilation sqlite storage, for messages, contacts, history" YES)
+ cmake_dependent_option(ENABLE_LIME "Enable Instant Messaging Encryption." YES "ENABLE_SQLITE_STORAGE" NO)
+ cmake_dependent_option(ENABLE_NOTIFY "Enable libnotify support." YES "ENABLE_GTK_UI;NOT APPLE" NO)
+-option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." NO)
+-option(ENABLE_STRICT "Build with strict compile options." YES)
++option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." YES)
++option(ENABLE_STRICT "Build with strict compile options." NO)
+ option(ENABLE_TOOLS "Turn on or off compilation of tools." YES)
+ option(ENABLE_TUNNEL "Turn on compilation of tunnel support." NO)
+ option(ENABLE_TUTORIALS "Enable compilation of tutorials." YES)