summarylogtreecommitdiffstats
path: root/linux-nitrous-git.install
diff options
context:
space:
mode:
authorSimao Gomes Viana2019-11-04 18:04:12 +0100
committerSimao Gomes Viana2019-11-04 18:17:19 +0100
commitae989f032350f0aa545e7afdbdf2c7aba58738ac (patch)
tree4bc9648362ac70cc039012c1ae7a259d539b47b6 /linux-nitrous-git.install
parentada3e499beb6fcf72d94916a7b1d70a05fcb47cb (diff)
downloadaur-ae989f032350f0aa545e7afdbdf2c7aba58738ac.tar.gz
Use linux-git as template
Thanks to the contributors mentioned in the PKGBUILD file
Diffstat (limited to 'linux-nitrous-git.install')
-rw-r--r--linux-nitrous-git.install37
1 files changed, 37 insertions, 0 deletions
diff --git a/linux-nitrous-git.install b/linux-nitrous-git.install
new file mode 100644
index 000000000000..ef42413835ac
--- /dev/null
+++ b/linux-nitrous-git.install
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=
+KERNEL_VERSION=
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+
+ if [ $(vercmp $2 3.13) -lt 0 ]; then
+ echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
+ echo ">>> In order to use your keyboard during early init, you MUST"
+ echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
+ fi
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+}