summarylogtreecommitdiffstats
path: root/makeSmath.sh
diff options
context:
space:
mode:
authortomracing2019-01-16 20:33:04 +0100
committertomracing2019-01-16 20:33:04 +0100
commit7ea243816d12de26f885d3fe98637770c5233694 (patch)
tree593879eb4d93a7f86c23527a6a6584d25ce19345 /makeSmath.sh
parentffd2a3f8c73e8ca48a3f1aef6961d5775e476fd9 (diff)
downloadaur-7ea243816d12de26f885d3fe98637770c5233694.tar.gz
fixed issues and updated url to smath.com
Diffstat (limited to 'makeSmath.sh')
-rwxr-xr-xmakeSmath.sh12
1 files changed, 7 insertions, 5 deletions
diff --git a/makeSmath.sh b/makeSmath.sh
index 0f75e57d2995..da177b5ca999 100755
--- a/makeSmath.sh
+++ b/makeSmath.sh
@@ -2,23 +2,25 @@
_pkgcode=XTRcr
pkgver=0_99_6670
+pkgrel=2
-wget --post-data "RefMem=&PostBack=${_pkgcode}" https://smath.info/file/${_pkgcode}/SMathStudioDesktop.${pkgver}.mono.tar.gz
+wget --post-data "RefMem=&PostBack=${_pkgcode}" https://smath.com/file/${_pkgcode}/SMathStudioDesktop.${pkgver}.mono.tar.gz
_pkgmd5sum=$(md5sum SMathStudioDesktop.${pkgver}.mono.tar.gz |awk '{ print $1 }')
# echo ${_pkgmd5sum}
sed -i "11s/.*/pkgver=${pkgver}/" PKGBUILD
+sed -i "12s/.*/pkgrel=${pkgrel}/" PKGBUILD
sed -i "14s/.*/_pkgcode=${_pkgcode}/" PKGBUILD
sed -i "23s/.*/md5sums=\(\'${_pkgmd5sum}\'\)/" PKGBUILD
rm SMathStudioDesktop.${pkgver}.mono.tar.gz
-#makepkg --printsrcinfo > .SRCINFO
+makepkg --printsrcinfo > .SRCINFO
#First do the git commit by hand
-# git add PKGBUILD .SRCINFO
-# git commit -m "Update to ${pkgver}"
+git add PKGBUILD .SRCINFO
+#git commit -m "Update to ${pkgver} rel=${pkgrel}"
# git push
-echo "Finished updating the SMATH package to ${pkgver}"
+echo "Finished updating the SMATH package to ${pkgver}-rel=${pkgrel}"