summarylogtreecommitdiffstats
path: root/makefile-system-htslib.patch
diff options
context:
space:
mode:
authorChristian Krause2016-01-10 11:44:28 +0100
committerChristian Krause2016-01-10 11:44:28 +0100
commitce0e65b4a554c65329bc40d6de30120fda1aa0ea (patch)
tree35760f062f5f98cd24d74bcce1f4430b3eb4be41 /makefile-system-htslib.patch
parent1c012681f904e3b3f380cb3eaefe5730f2357d8c (diff)
downloadaur-ce0e65b4a554c65329bc40d6de30120fda1aa0ea.tar.gz
bcftools-1.3-1
Diffstat (limited to 'makefile-system-htslib.patch')
-rw-r--r--makefile-system-htslib.patch136
1 files changed, 88 insertions, 48 deletions
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
index 737ab0d61d5d..9965be1135d7 100644
--- a/makefile-system-htslib.patch
+++ b/makefile-system-htslib.patch
@@ -1,78 +1,118 @@
-diff -aur bcftools-1.2/Makefile bcftools-1.2-patched/Makefile
---- bcftools-1.2/Makefile 2015-02-02 16:40:17.000000000 +0100
-+++ bcftools-1.2-patched/Makefile 2015-02-04 12:33:10.627010914 +0100
-@@ -29,11 +29,9 @@
+--- Makefile.orig 2016-01-10 11:15:35.126733492 +0100
++++ Makefile 2016-01-10 11:21:31.034859116 +0100
+@@ -28,13 +28,6 @@
+
all: $(PROG) $(TEST_PROG)
- # Adjust $(HTSDIR) to point to your top-level htslib directory
--HTSDIR = ../htslib
+-# Adjust $(HTSDIR) to point to your top-level htslib directory
+-HTSDIR = htslib-1.3
-include $(HTSDIR)/htslib.mk
-HTSLIB = $(HTSDIR)/libhts.a
-BGZIP = $(HTSDIR)/bgzip
-TABIX = $(HTSDIR)/tabix
-+HTSDIR = /usr/include
-+BGZIP = bgzip
-+TABIX = tabix
-
+-
CC = gcc
+ CPPFLAGS =
CFLAGS = -g -Wall -Wc++-compat -O2
-@@ -52,7 +50,7 @@
+@@ -48,7 +41,7 @@
+ vcfcnv.o HMM.o vcfplugin.o consensus.o ploidy.o version.o \
+ ccall.o em.o prob1.o kmin.o # the original samtools calling
+
+-EXTRA_CPPFLAGS = -I. -I$(HTSDIR) -DPLUGINPATH=\"$(pluginpath)\"
++EXTRA_CPPFLAGS = -I. -DPLUGINPATH=\"$(pluginpath)\"
+ GSL_LIBS =
+
+ # The polysomy command is not compiled by default because it brings dependency
+@@ -57,7 +50,7 @@
ifdef USE_GPL
- CFLAGS += -DUSE_GPL
- OBJS += polysomy.o
-- LDLIBS = -lgsl -lcblas
-+ LDLIBS = -lgsl -lgslcblas
+ EXTRA_CPPFLAGS += -DUSE_GPL
+ OBJS += polysomy.o peakfit.o
+- GSL_LIBS = -lgsl -lcblas
++ GSL_LIBS = -lgsl -lgslcblas
endif
prefix = /usr/local
-@@ -90,10 +88,10 @@
+@@ -101,11 +94,11 @@
.c.o:
- $(CC) -c $(CFLAGS) $(DFLAGS) $(INCLUDES) $< -o $@
+ $(CC) $(CFLAGS) $(EXTRA_CPPFLAGS) $(CPPFLAGS) -c -o $@ $<
-test: $(PROG) plugins test/test-rbuf $(BGZIP) $(TABIX)
+- ./test/test.pl --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
+test: $(PROG) plugins test/test-rbuf
- ./test/test.pl --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
++ ./test/test.pl --exec bgzip=bgzip --exec tabix=tabix
-test-plugins: $(PROG) plugins test/test-rbuf $(BGZIP) $(TABIX)
+- ./test/test.pl --plugins --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
+test-plugins: $(PROG) plugins test/test-rbuf
- ./test/test.pl --plugins --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
-
++ ./test/test.pl --plugins --exec bgzip=bgzip --exec tabix=tabix
-@@ -102,8 +100,8 @@
- PLUGINS = $(PLUGINC:.c=.so)
- PLUGINM = $(PLUGINC:.c=.mk)
--%.so: %.c version.h version.c $(HTSDIR)/libhts.so
-- $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ version.c $< -L$(HTSDIR) -lhts
-+%.so: %.c version.h version.c
-+ $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ version.c $< -lhts
+ # Plugin rules
+@@ -136,20 +129,20 @@
+ filter_h = filter.h $(htslib_vcf_h)
+ ploidy_h = ploidy.h $(htslib_regidx_h)
+ prob1_h = prob1.h $(htslib_vcf_h) $(call_h)
+-roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kstring.h $(HTSDIR)/htslib/kseq.h $(bcftools_h)
++roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
+ cnv_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h)
- -include $(PLUGINM)
+ main.o: main.c $(htslib_hts_h) version.h $(bcftools_h)
+-vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
+-vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
+-vcfcall.o: vcfcall.c $(htslib_vcf_h) $(HTSDIR)/htslib/kfunc.h $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/khash_str2int.h $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
+-vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
++vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
++vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
++vcfcall.o: vcfcall.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
++vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
+ vcfconvert.o: vcfconvert.c $(htslib_vcf_h) $(htslib_bgzf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h) $(tsv2vcf_h)
+ vcffilter.o: vcffilter.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) rbuf.h
+ vcfgtcheck.o: vcfgtcheck.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
+ vcfindex.o: vcfindex.c $(htslib_vcf_h) $(htslib_tbx_h)
+ vcfisec.o: vcfisec.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
+-vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h $(HTSDIR)/htslib/khash.h
++vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h
+ vcfnorm.o: vcfnorm.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_faidx_h) $(bcftools_h) rbuf.h
+ vcfquery.o: vcfquery.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h)
+ vcfroh.o: vcfroh.c $(roh_h)
+@@ -157,22 +150,22 @@
+ vcfsom.o: vcfsom.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
+ vcfstats.o: vcfstats.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(htslib_faidx_h) $(bcftools_h)
+ vcfview.o: vcfview.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
+-reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
++reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(bcftools_h)
+ tabix.o: tabix.c $(htslib_bgzf_h) $(htslib_tbx_h)
+-ccall.o: ccall.c $(HTSDIR)/htslib/kfunc.h $(call_h) kmin.h $(prob1_h)
++ccall.o: ccall.c $(call_h) kmin.h $(prob1_h)
+ convert.o: convert.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(convert_h)
+ tsv2vcf.o: tsv2vcf.c $(tsv2vcf_h)
+ em.o: em.c $(htslib_vcf_h) kmin.h $(call_h)
+-filter.o: filter.c $(HTSDIR)/htslib/khash_str2int.h $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
++filter.o: filter.c $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
+ gvcf.o: gvcf.c $(call_h)
+ kmin.o: kmin.c kmin.h
+-mcall.o: mcall.c $(HTSDIR)/htslib/kfunc.h $(call_h)
++mcall.o: mcall.c $(call_h)
+ prob1.o: prob1.c $(prob1_h)
+ vcmp.o: vcmp.c $(htslib_hts_h) vcmp.h
+-ploidy.o: ploidy.c $(htslib_regidx_h) $(HTSDIR)/htslib/khash_str2int.h $(HTSDIR)/htslib/kseq.h $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
++ploidy.o: ploidy.c $(htslib_regidx_h) $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
+ polysomy.o: polysomy.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) peakfit.h
+-peakfit.o: peakfit.c peakfit.h $(htslib_hts_h) $(HTSDIR)/htslib/kstring.h
+-consensus.o: consensus.c $(htslib_hts_h) $(HTSDIR)/htslib/kseq.h rbuf.h $(bcftools_h) $(HTSDIR)/htslib/regidx.h
++peakfit.o: peakfit.c peakfit.h $(htslib_hts_h)
++consensus.o: consensus.c $(htslib_hts_h) rbuf.h $(bcftools_h)
+ version.o: version.h version.c
-@@ -158,8 +156,8 @@
+ test/test-rbuf.o: test/test-rbuf.c rbuf.h
+@@ -180,8 +173,8 @@
test/test-rbuf: test/test-rbuf.o
- $(CC) $(CFLAGS) -o $@ -lm -ldl $<
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS)
-bcftools: $(HTSLIB) $(OBJS)
-- $(CC) $(CFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread -lz -lm -ldl $(LDLIBS)
+- $(CC) -rdynamic $(LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread -lz -lm -ldl $(GSL_LIBS) $(LIBS)
+bcftools: $(OBJS)
-+ $(CC) $(CFLAGS) -o $@ $(OBJS) -lpthread -lz -lm -ldl -lhts $(LDLIBS)
++ $(CC) -rdynamic $(LDFLAGS) -o $@ $(OBJS) -lhts -lpthread -lz -lm -ldl $(GSL_LIBS) $(LIBS)
doc/bcftools.1: doc/bcftools.txt
cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt
-diff -aur bcftools-1.2/plugins/fixploidy.mk bcftools-1.2-patched/plugins/fixploidy.mk
---- bcftools-1.2/plugins/fixploidy.mk 2015-02-02 16:40:17.000000000 +0100
-+++ bcftools-1.2-patched/plugins/fixploidy.mk 2015-02-04 12:23:15.376535358 +0100
-@@ -1,2 +1,2 @@
--plugins/fixploidy.so: plugins/fixploidy.c version.h version.c ploidy.h ploidy.c $(HTSDIR)/libhts.so
-- $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ ploidy.c version.c $< -L$(HTSDIR) -lhts
-+plugins/fixploidy.so: plugins/fixploidy.c version.h version.c ploidy.h ploidy.c
-+ $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ ploidy.c version.c $< -lhts
-diff -aur bcftools-1.2/plugins/vcf2sex.mk bcftools-1.2-patched/plugins/vcf2sex.mk
---- bcftools-1.2/plugins/vcf2sex.mk 2015-02-02 16:40:17.000000000 +0100
-+++ bcftools-1.2-patched/plugins/vcf2sex.mk 2015-02-04 12:25:51.240884001 +0100
-@@ -1,2 +1,2 @@
--plugins/vcf2sex.so: plugins/vcf2sex.c version.h version.c ploidy.h ploidy.c $(HTSDIR)/libhts.so
-- $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ ploidy.c version.c $< -L$(HTSDIR) -lhts
-+plugins/vcf2sex.so: plugins/vcf2sex.c version.h version.c ploidy.h ploidy.c
-+ $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ ploidy.c version.c $< -lhts