summarylogtreecommitdiffstats
path: root/makefile.patch
diff options
context:
space:
mode:
authorMatti Niemenmaa2015-05-14 16:59:31 +0300
committerMatti Niemenmaa2015-07-14 16:04:51 +0300
commit819d07b59ac794609aafd4cacc2f95b4cd1f2c20 (patch)
treeaa194b98abea278cd3260936f76103366c85f9b2 /makefile.patch
parentecfa0bee6f153a0194115a149e59c28957ffab16 (diff)
downloadaur-819d07b59ac794609aafd4cacc2f95b4cd1f2c20.tar.gz
Link with -Bsymbolic to reduce symbol leak issues
Plenty of internal symbols are exported, with rather generic names that can (and do) conflict with other libraries. So link with -Bsymbolic, which prevents overriding them with LD_PRELOAD but also prevents such conflicts from causing problems with functions here accidentally calling some other library's functions.
Diffstat (limited to 'makefile.patch')
-rw-r--r--makefile.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/makefile.patch b/makefile.patch
index 2c2fb1268631..b3b317a2b9a9 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -16,7 +16,7 @@ diff --git i/Makefile w/Makefile
$(AR) rcs $@ $^
+liblazyusf.so : $(OBJS)
-+ $(CC) $(CFLAGS) -shared -lm -lz -o $@ $^
++ $(CC) $(CFLAGS) -Wl,-Bsymbolic -shared -lm -lz -o $@ $^
+
bench : test/bench.o liblazyusf.a
$(CC) -o $@ $^ ../psflib/libpsflib.a -lz