summarylogtreecommitdiffstats
path: root/makefile
diff options
context:
space:
mode:
authorFabien JUIF2016-03-16 20:01:18 +0100
committerFabien JUIF2016-03-16 20:01:18 +0100
commit506c762609644738cbfcd44b5440f91f06a869d7 (patch)
tree6beaecc31aa3459967f534eb2cefae5a13df167f /makefile
downloadaur-506c762609644738cbfcd44b5440f91f06a869d7.tar.gz
Initial commit
Diffstat (limited to 'makefile')
-rw-r--r--makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..84e1ca56602a
--- /dev/null
+++ b/makefile
@@ -0,0 +1,19 @@
+all: clean main lint install
+
+clean:
+ rm -Rf pkg
+ rm -Rf src
+ rm -Rf superpowers
+ rm -Rf superpowers*.zip
+ rm -Rf *superpowers-*.pkg.tar.xz
+
+lint:
+ namcap PKGBUILD
+ namcap *superpowers-*.pkg.tar.xz
+
+main:
+ makepkg
+ mksrcinfo
+
+install:
+ sudo pacman -U *superpowers-*.pkg.tar.xz