summarylogtreecommitdiffstats
path: root/mallocng.patch
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-05-28 15:05:46 +0200
committerFrancesco Minnocci2021-05-28 15:05:46 +0200
commit9c823e0618469f61ef1312bd1b491b8b933a8f17 (patch)
treea3c892e91e85d131d03ea08708ed6d4f84057592 /mallocng.patch
parentd1394db0cb3ad495e8cd3bb81ca7281e5fc0a3fe (diff)
downloadaur-9c823e0618469f61ef1312bd1b491b8b933a8f17.tar.gz
Add patch for building with gcc11; move gtk3 and webkit2gtk in makedeps
Diffstat (limited to 'mallocng.patch')
-rw-r--r--mallocng.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/mallocng.patch b/mallocng.patch
new file mode 100644
index 000000000000..d4288b654177
--- /dev/null
+++ b/mallocng.patch
@@ -0,0 +1,23 @@
+diff --git a/.gitmodules b/.gitmodules
+index beda934f6..01f7cbb83 100644
+--- a/.gitmodules
++++ b/.gitmodules
+@@ -91,3 +91,6 @@
+ [submodule "Telegram/lib_webview"]
+ path = Telegram/lib_webview
+ url = https://github.com/kotatogram/lib_webview.git
++[submodule "Telegram/ThirdParty/mallocng"]
++ path = Telegram/ThirdParty/mallocng
++ url = https://github.com/desktop-app/mallocng.git
+diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
+index 0e00fcee1..fed1f9634 100644
+--- a/Telegram/CMakeLists.txt
++++ b/Telegram/CMakeLists.txt
+@@ -89,6 +89,7 @@ elseif (LINUX)
+ PRIVATE
+ desktop-app::external_glibmm
+ desktop-app::external_glib
++ desktop-app::external_mallocng
+ )
+
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)