summarylogtreecommitdiffstats
path: root/merge-with-testing
diff options
context:
space:
mode:
authorMikael Eriksson2023-07-10 00:40:11 +0200
committerMikael Eriksson2023-07-10 00:40:11 +0200
commit063c45642682207deb55438db26deab61725f45c (patch)
tree23130873da562fa1fac48898fcd87eb811e9f039 /merge-with-testing
parentb39528f5fd226e2321968a0374c970c75ec9e988 (diff)
downloadaur-063c45642682207deb55438db26deab61725f45c.tar.gz
Update merge script to use the arch git repo
Diffstat (limited to 'merge-with-testing')
-rw-r--r--merge-with-testing6
1 files changed, 2 insertions, 4 deletions
diff --git a/merge-with-testing b/merge-with-testing
index 97359c11f010..68ce0b1375b8 100644
--- a/merge-with-testing
+++ b/merge-with-testing
@@ -8,13 +8,11 @@ fi
if ! git remote|grep -q arch; then
echo "Adding 'arch' remote"
- git remote add arch git://projects.archlinux.org/svntogit/packages.git
- git remote set-branches arch packages/linux
+ git remote add arch https://gitlab.archlinux.org/archlinux/packaging/packages/linux.git
fi
git fetch arch
-git checkout -b merge --no-track arch/packages/linux
-FILTER_BRANCH_SQUELCH_WARNING=1 git filter-branch -f --subdirectory-filter trunk/
+git checkout -b merge --no-track arch/main
grep ^pkgver PKGBUILD
grep ^pkgrel PKGBUILD
git checkout master