summarylogtreecommitdiffstats
path: root/merge-with-testing
diff options
context:
space:
mode:
authorMikael Eriksson2016-02-01 14:35:05 +0100
committerMikael Eriksson2016-02-01 14:36:55 +0100
commit565c618bf709a0613118d3e8576d7859b8d5b10b (patch)
treec717542f3241faefe9a13e78ebd02c96a637ad07 /merge-with-testing
parented9565c8a2694b42cc7afdfd44c32b0c3f7b8a45 (diff)
downloadaur-565c618bf709a0613118d3e8576d7859b8d5b10b.tar.gz
Added script to merge with testing/linux
Diffstat (limited to 'merge-with-testing')
-rw-r--r--merge-with-testing25
1 files changed, 25 insertions, 0 deletions
diff --git a/merge-with-testing b/merge-with-testing
new file mode 100644
index 000000000000..6bf61e7aba10
--- /dev/null
+++ b/merge-with-testing
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+set -e
+
+if git branch|grep -q merge; then
+ git branch -D merge
+fi
+
+if ! git remote|grep -q arch; then
+ echo "Adding 'arch' remote"
+ git remote add arch git://projects.archlinux.org/svntogit/packages.git
+ git remote set-branches arch packages/linux
+fi
+
+git fetch arch
+git checkout -b merge --no-track arch/packages/linux
+git filter-branch -f --subdirectory-filter trunk/
+grep ^pkgver PKGBUILD
+grep ^pkgrel PKGBUILD
+git checkout master
+
+echo "Automerging configs"
+git checkout merge -- config config.x86_64
+
+echo "All done, you can now do git checkout --patch merge PKGBUILD"