summarylogtreecommitdiffstats
path: root/mimick_vendor.patch
diff options
context:
space:
mode:
authormjbogusz2021-06-12 22:16:27 +0200
committerMohammad Farzan2021-06-20 02:31:31 +0430
commit9be4a4d8c4a75e1df1bcacdb11314b79763f914c (patch)
tree18f2c17b15c44eb6002e683ca46c4aab04ef5ed6 /mimick_vendor.patch
parent9cdfe77176956d945d5fdce7de2dd30f9136ebc8 (diff)
downloadaur-9be4a4d8c4a75e1df1bcacdb11314b79763f914c.tar.gz
galactic: 1st version
Diffstat (limited to 'mimick_vendor.patch')
-rw-r--r--mimick_vendor.patch16
1 files changed, 13 insertions, 3 deletions
diff --git a/mimick_vendor.patch b/mimick_vendor.patch
index d86f3c8d48b5..f4bbf2fc4160 100644
--- a/mimick_vendor.patch
+++ b/mimick_vendor.patch
@@ -1,3 +1,13 @@
-10a11,12
-> list(APPEND cmake_configure_args -DCMAKE_C_FLAGS="-O2")
-> list(APPEND cmake_configure_args -DCMAKE_CXX_FLAGS="-O2")
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e4cf591..54e4852 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,8 @@ macro(build_mimick)
+
+ set(cmake_commands)
+ set(cmake_configure_args -Wno-dev)
++ list(APPEND cmake_configure_args -DCMAKE_C_FLAGS="-O2")
++ list(APPEND cmake_configure_args -DCMAKE_CXX_FLAGS="-O2")
+ list(APPEND cmake_configure_args -DCMAKE_INSTALL_PREFIX=${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}_install)
+
+ if(WIN32)