summarylogtreecommitdiffstats
path: root/minecraftd.conf
diff options
context:
space:
mode:
authorGordian Edenhofer2016-06-24 17:14:20 +0200
committerGordian Edenhofer2016-06-24 17:41:00 +0200
commitde963801f56601d7b0e050332404c5513ac3bbe1 (patch)
treeee1f3bf30f6887b3cf8a82378f5a7e2aab477240 /minecraftd.conf
parent3a2205fcecbc463a35f50b1f85172a47774c0d0e (diff)
downloadaur-de963801f56601d7b0e050332404c5513ac3bbe1.tar.gz
upgpkg: minecraft-server 1.10.2-2
* Handle server command output completely through screen instead of relying on a possible outdated log file. (Implemented in the game_command function.) The default screen command dump resides in /tmp. * LOGPATH is not needed anymore. * Unite various java options into one lengthier SERVER_START_CMD. * Update configuration file accordingly. * Create log dir in PKGBUILD. * Fix some style inconsistencies.
Diffstat (limited to 'minecraftd.conf')
-rw-r--r--minecraftd.conf9
1 files changed, 4 insertions, 5 deletions
diff --git a/minecraftd.conf b/minecraftd.conf
index 1c59ab401b16..2b795dca6e0b 100644
--- a/minecraftd.conf
+++ b/minecraftd.conf
@@ -4,7 +4,6 @@
# General parameters
SERVER_ROOT="/srv/minecraft"
BACKUP_DEST="/srv/minecraft/backup"
-LOGPATH="/srv/minecraft/logs"
BACKUP_PATHS="world" # World paths separated by spaces relative to SERVER_ROOT
KEEP_BACKUPS="10"
GAME_USER="minecraft"
@@ -12,10 +11,10 @@ MAIN_EXECUTABLE="minecraft_server.jar"
SESSION_NAME="minecraft"
# System parameters for java
-MINHEAP="512M"
-MAXHEAP="1024M"
-THREADS="1"
-JAVA_PARMS="-Xmx${MAXHEAP} -Xms${MINHEAP} -XX:ParallelGCThreads=${THREADS}"
+# -Xms sets the intial heap size (must be a multiple of 1024 and greater than 2MB, no spaces!)
+# -Xmx sets the maximum heap size (must be a multiple of 1024 and greater than 2MB, no spaces!)
+# -XX:ParallelGCThreads defines the number of threads the server may use
+SERVER_START_CMD="java -Xms512M -Xmx1024M -XX:ParallelGCThreads=1 -jar './${MAIN_EXECUTABLE}' nogui"
# System parameters for the actual game server
# Describes whether a daemon process which stops the server if it is not used by a player