summarylogtreecommitdiffstats
path: root/minimize.patch
diff options
context:
space:
mode:
authors3rj1k2022-04-24 22:07:38 +0300
committers3rj1k2022-04-24 22:07:38 +0300
commit2521e2f9a1fe6e2df3118e651c3f5ec50e507d24 (patch)
tree9ce3a2de713a588b2319dd96142e649735d0d443 /minimize.patch
parent6871b472ddffde81dd88c61692619b832b561161 (diff)
downloadaur-2521e2f9a1fe6e2df3118e651c3f5ec50e507d24.tar.gz
Minimal applets list
Signed-off-by: s3rj1k <evasive.gyron@gmail.com>
Diffstat (limited to 'minimize.patch')
-rw-r--r--minimize.patch77
1 files changed, 13 insertions, 64 deletions
diff --git a/minimize.patch b/minimize.patch
index 4127a207715d..88a0a714dcc7 100644
--- a/minimize.patch
+++ b/minimize.patch
@@ -347,17 +347,17 @@ index 8c086344e..9bd400e46 100644
if ENABLE_DOCUMENTATION
SUBDIRS += $(DIST_SUBDIRS)
diff --git a/modules/Makefile.am b/modules/Makefile.am
-index ee1ae0bf6..ba69b7d58 100644
+index ee1ae0bf6..a488ae9aa 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
-@@ -1,14 +1,9 @@
+@@ -1,14 +1,8 @@
NULL =
SUBDIRS = \
- action-button \
- clock \
- fish \
- launcher \
+- launcher \
- menu \
notification-area \
separator \
@@ -365,59 +365,8 @@ index ee1ae0bf6..ba69b7d58 100644
wncklet \
$(NULL)
-diff --git a/modules/launcher/Makefile.am b/modules/launcher/Makefile.am
-index d336374c5..929ffcd1c 100644
---- a/modules/launcher/Makefile.am
-+++ b/modules/launcher/Makefile.am
-@@ -27,13 +27,8 @@ org_gnome_gnome_panel_launcher_la_SOURCES = \
- gp-editor.h \
- gp-icon-name-chooser.c \
- gp-icon-name-chooser.h \
-- gp-launcher-applet.c \
- gp-launcher-applet.h \
-- gp-launcher-button.c \
-- gp-launcher-button.h \
- gp-launcher-module.c \
-- gp-launcher-properties.c \
-- gp-launcher-properties.h \
- gp-launcher-utils.c \
- gp-launcher-utils.h \
- $(BUILT_SOURCES) \
-diff --git a/modules/launcher/gp-custom-launcher-applet.c b/modules/launcher/gp-custom-launcher-applet.c
-index d29724686..5fffbe2cc 100644
---- a/modules/launcher/gp-custom-launcher-applet.c
-+++ b/modules/launcher/gp-custom-launcher-applet.c
-@@ -34,7 +34,7 @@ struct _GpCustomLauncherApplet
-
- G_DEFINE_TYPE (GpCustomLauncherApplet,
- gp_custom_launcher_applet,
-- GP_TYPE_LAUNCHER_APPLET)
-+ GP_TYPE_CUSTOM_LAUNCHER_APPLET)
-
- static LauncherData *
- launcher_data_new (GpInitialSetupDialog *dialog)
-diff --git a/modules/launcher/gp-launcher-module.c b/modules/launcher/gp-launcher-module.c
-index 336918319..197951e1d 100644
---- a/modules/launcher/gp-launcher-module.c
-+++ b/modules/launcher/gp-launcher-module.c
-@@ -61,15 +61,6 @@ launcher_get_applet_info (const gchar *id)
- initial_setup_func = gp_custom_launcher_applet_initial_setup_dialog;
- is_disabled_func = custom_launcher_is_disabled;
- }
-- else if (g_strcmp0 (id, "launcher") == 0)
-- {
-- type_func = gp_launcher_applet_get_type;
-- name = _("Application Launcher...");
-- description = _("Copy a launcher from the applications menu");
-- icon = "gnome-panel-launcher";
--
-- initial_setup_func = gp_launcher_applet_initial_setup_dialog;
-- }
- else
- {
- g_assert_not_reached ();
diff --git a/po/POTFILES.in b/po/POTFILES.in
-index fd6cfd5cb..004cb4f9a 100644
+index fd6cfd5cb..b587dfa59 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,7 +1,5 @@
@@ -428,7 +377,7 @@ index fd6cfd5cb..004cb4f9a 100644
data/org.gnome.gnome-panel.applet.window-list.gschema.xml
data/org.gnome.gnome-panel.applet.workspace-switcher.gschema.xml
data/org.gnome.gnome-panel.gschema.xml
-@@ -23,60 +21,22 @@ gnome-panel/panel-bindings.c
+@@ -23,60 +21,14 @@ gnome-panel/panel-bindings.c
gnome-panel/panel.c
gnome-panel/panel-context-menu.c
gnome-panel/panel-layout.c
@@ -460,16 +409,16 @@ index fd6cfd5cb..004cb4f9a 100644
-modules/fish/fish-module.c
-modules/fish/fish-menu.ui
-modules/fish/fish.ui
- modules/launcher/custom-launcher-menu.ui
- modules/launcher/gp-editor.c
- modules/launcher/gp-icon-name-chooser.c
- modules/launcher/gp-icon-name-chooser.ui
+-modules/launcher/custom-launcher-menu.ui
+-modules/launcher/gp-editor.c
+-modules/launcher/gp-icon-name-chooser.c
+-modules/launcher/gp-icon-name-chooser.ui
-modules/launcher/gp-launcher-applet.c
- modules/launcher/gp-launcher-module.c
+-modules/launcher/gp-launcher-module.c
-modules/launcher/gp-launcher-properties.c
- modules/launcher/gp-launcher-utils.c
- modules/launcher/launcher-menu.ui
- modules/launcher/org.gnome.gnome-panel.applet.launcher.gschema.xml
+-modules/launcher/gp-launcher-utils.c
+-modules/launcher/launcher-menu.ui
+-modules/launcher/org.gnome.gnome-panel.applet.launcher.gschema.xml
-modules/menu/gp-bookmarks.c
-modules/menu/gp-lock-logout.c
-modules/menu/gp-menu-bar-applet.c