summarylogtreecommitdiffstats
path: root/native-menu-doc-listener.patch
diff options
context:
space:
mode:
authorIsabell Cowan2017-10-05 23:34:21 -0500
committerIsabell Cowan2017-10-05 23:34:21 -0500
commit82ee89ac47d29104c242df39ad4900aa4710880e (patch)
tree62b785351f8843ab594eab7bf36677ebd9789ba2 /native-menu-doc-listener.patch
parent9740a36c9030c80a6aad664251e280b2377a80a0 (diff)
downloadaur-82ee89ac47d29104c242df39ad4900aa4710880e.tar.gz
Bumped to 57.0b5-2
* Renamed sources and patches for consistency and versioning. * Added messages and warnings to PKGBUILD. * Utilized the ./mach build system wrapper. * Updated mozconfig and dependencies. * Included many parameters for the build in the PKGBUILD header. * Patched nsNativeMenuDocListener for unity-menubar.patch
Diffstat (limited to 'native-menu-doc-listener.patch')
-rw-r--r--native-menu-doc-listener.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/native-menu-doc-listener.patch b/native-menu-doc-listener.patch
new file mode 100644
index 000000000000..5cc90c9ecae8
--- /dev/null
+++ b/native-menu-doc-listener.patch
@@ -0,0 +1,22 @@
+--- a/widget/gtk/nsNativeMenuDocListener.cpp
++++ b/widget/gtk/nsNativeMenuDocListener.cpp
+@@ -64,7 +64,8 @@
+ {
+ MOZ_ASSERT(mContentToObserverTable.Count() == 0,
+ "Some nodes forgot to unregister listeners. This is bad! (and we're lucky we made it this far)");
+- MOZ_COUNT_DTOR(nsNativeMenuDocListener);
++ // This shouldn't be here? https://bugzilla.mozilla.org/show_bug.cgi?id=977380
++ // MOZ_COUNT_DTOR(nsNativeMenuDocListener);
+ }
+
+ void
+@@ -287,7 +288,8 @@
+ mLastSource(nullptr),
+ mLastTarget(nullptr)
+ {
+- MOZ_COUNT_CTOR(nsNativeMenuDocListener);
++ // This shouldn't be here, see destructor for details.
++ // MOZ_COUNT_CTOR(nsNativeMenuDocListener);
+ }
+
+ void