summarylogtreecommitdiffstats
path: root/nginx.install
diff options
context:
space:
mode:
authorGoliathLabs2020-04-19 18:23:25 +0200
committerGoliathLabs2020-04-19 18:23:25 +0200
commit638439d02e195f170b1baf6bed45d25f6dae3191 (patch)
tree8fbce90104f6b1390ab45ae2878a4327904f71de /nginx.install
parent6b8a38cef8dc252da36890f4e1200536bbbe040a (diff)
downloadaur-638439d02e195f170b1baf6bed45d25f6dae3191.tar.gz
Updated: PKGBUILD
Diffstat (limited to 'nginx.install')
-rw-r--r--nginx.install12
1 files changed, 12 insertions, 0 deletions
diff --git a/nginx.install b/nginx.install
new file mode 100644
index 000000000000..90d24a5905b3
--- /dev/null
+++ b/nginx.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ if (( $(vercmp $2 1.11.8-2) < 0)); then
+ chown root:root var/log/nginx
+ fi
+
+ if (( $(vercmp $2 1.11.9-2) < 0 )); then
+ chmod 755 var/log/nginx
+ echo ':: Security notice:'
+ echo ' - When additional log directories are used in /var/log/nginx make sure they'
+ echo ' are owned by root:root and have 755 set as permission to mitigate CVE-2016-1247'
+ fi
+}