summarylogtreecommitdiffstats
path: root/no-relinking.patch
diff options
context:
space:
mode:
authornikatar2019-10-08 21:08:09 +0300
committernikatar2019-10-08 21:08:09 +0300
commitb381c6f1f87e16361ddbc2e85a330836d3c1fde9 (patch)
tree3788ba5aa891209e44e486651472a892a71970be /no-relinking.patch
parent098669151c36838a69957b6330d9b27b3487b685 (diff)
downloadaur-b381c6f1f87e16361ddbc2e85a330836d3c1fde9.tar.gz
69.0.2-1
Diffstat (limited to 'no-relinking.patch')
-rw-r--r--no-relinking.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/no-relinking.patch b/no-relinking.patch
new file mode 100644
index 000000000000..6dd988402d9c
--- /dev/null
+++ b/no-relinking.patch
@@ -0,0 +1,41 @@
+
+# HG changeset patch
+# User Mike Shal <mshal@mozilla.com>
+# Date 1570127498 25200
+# Node ID b8bc2504f108d8a2216ee11405cbbe4cf7a0eaec
+# Parent 9a4d6aacc48080f019024c02ac7da1fd576b39fe
+Bug XYZ - Only force re-linking on 1-tier PGO builds; r?#firefox-build-system-reviewers
+
+
+diff --git a/config/rules.mk b/config/rules.mk
+--- a/config/rules.mk
++++ b/config/rules.mk
+@@ -465,25 +465,27 @@ ifeq ($(OS_ARCH)_$(GNU_CC), WINNT_)
+ $(foreach pgd,$(wildcard *.pgd),pgomgr -clear $(pgd);)
+ else
+ ifdef GNU_CC
+ -$(RM) *.gcda
+ endif
+ endif
+ endif
+
++ifdef MOZ_1TIER_PGO
+ ifneq (,$(MOZ_PROFILE_GENERATE)$(MOZ_PROFILE_USE))
+ ifneq (,$(filter target,$(MAKECMDGOALS)))
+ ifdef GNU_CC
+ # Force rebuilding libraries and programs in both passes because each
+ # pass uses different object files.
+ $(PROGRAM) $(SHARED_LIBRARY) $(LIBRARY): FORCE
+ endif
+ endif
+ endif
++endif
+
+ endif # NO_PROFILE_GUIDED_OPTIMIZE
+
+ ##############################################
+
+ clean clobber realclean clobber_all::
+ -$(RM) $(ALL_TRASH)
+ -$(RM) -r $(ALL_TRASH_DIRS)
+