summarylogtreecommitdiffstats
path: root/no-tests.patch
diff options
context:
space:
mode:
authorAlexandre Macabies2020-09-25 01:52:07 +0200
committerAlexandre Macabies2020-09-25 01:52:54 +0200
commitaff70f26f972b78726e7d024bcab2ffc0e5e65c6 (patch)
tree284aa719aac9c41001873bef3999674ed41c799b /no-tests.patch
parent89f29fda60f99d7183dbc0c8d4c1e7b4be1eb15f (diff)
downloadaur-aff70f26f972b78726e7d024bcab2ffc0e5e65c6.tar.gz
Build for Lua 5.4 and remove packaged tests.
Diffstat (limited to 'no-tests.patch')
-rw-r--r--no-tests.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/no-tests.patch b/no-tests.patch
new file mode 100644
index 000000000000..7512275c7ad3
--- /dev/null
+++ b/no-tests.patch
@@ -0,0 +1,21 @@
+diff --unified --recursive --text lua-cjson-2.1.0.old/Makefile lua-cjson-2.1.0.new/Makefile
+--- lua-cjson-2.1.0.old/Makefile 2012-03-01 13:22:50.000000000 +0100
++++ lua-cjson-2.1.0.new/Makefile 2020-09-25 01:41:33.188384712 +0200
+@@ -104,16 +104,13 @@
+ chmod $(EXECPERM) $(DESTDIR)/$(LUA_CMODULE_DIR)/$(TARGET)
+
+ install-extra:
+- mkdir -p $(DESTDIR)/$(LUA_MODULE_DIR)/cjson/tests \
+- $(DESTDIR)/$(LUA_BIN_DIR)
++ mkdir -p $(DESTDIR)/$(LUA_MODULE_DIR)/cjson $(DESTDIR)/$(LUA_BIN_DIR)
+ cp lua/cjson/util.lua $(DESTDIR)/$(LUA_MODULE_DIR)/cjson
+ chmod $(DATAPERM) $(DESTDIR)/$(LUA_MODULE_DIR)/cjson/util.lua
+ cp lua/lua2json.lua $(DESTDIR)/$(LUA_BIN_DIR)/lua2json$(LUA_BIN_SUFFIX)
+ chmod $(EXECPERM) $(DESTDIR)/$(LUA_BIN_DIR)/lua2json$(LUA_BIN_SUFFIX)
+ cp lua/json2lua.lua $(DESTDIR)/$(LUA_BIN_DIR)/json2lua$(LUA_BIN_SUFFIX)
+ chmod $(EXECPERM) $(DESTDIR)/$(LUA_BIN_DIR)/json2lua$(LUA_BIN_SUFFIX)
+- cd tests; cp $(TEST_FILES) $(DESTDIR)/$(LUA_MODULE_DIR)/cjson/tests
+- cd tests; chmod $(DATAPERM) $(TEST_FILES); chmod $(EXECPERM) *.lua *.pl
+
+ clean:
+ rm -f *.o $(TARGET)