summarylogtreecommitdiffstats
path: root/nwn.install
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit656757ae26ab4a1aa0f8acbfc12ad76137f99d28 (patch)
tree388c481614dcea503e2095649cb0dcd595bf23ef /nwn.install
downloadaur-656757ae26ab4a1aa0f8acbfc12ad76137f99d28.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
Diffstat (limited to 'nwn.install')
-rw-r--r--nwn.install35
1 files changed, 35 insertions, 0 deletions
diff --git a/nwn.install b/nwn.install
new file mode 100644
index 000000000000..e8bfa88fe72b
--- /dev/null
+++ b/nwn.install
@@ -0,0 +1,35 @@
+
+post_install() {
+ echo ">>> If you use software mixing on your sound card, uncomment the"
+ echo ">>> first export statement in /usr/bin/nwn to make that work"
+ echo ">>>"
+ echo ">>> Some of the additional modules create .ini files the first time"
+ echo ">>> they start. You may have to restart nwn a few times for it"
+ echo ">>> load successfully. This is normal. Run 'nwn' from a terminal the"
+ echo ">>> first few times until the game starts running correctly."
+ echo ">>>"
+ echo ">>> If something throws an error saying it cannot create the .ini file, "
+ echo ">>> try modifying the export LD_PRELOAD line in /usr/bin/nwn to"
+ echo ">>> include just one additional library at a time. For example:"
+ echo ">>>"
+ echo ">>> export LD_PRELOAD=./nwuser.so (start nwn)"
+ echo ">>> export LD_PRELOAD=./nwuser.so:./nwmouse.so (start nwn)"
+ echo ">>> export LD_PRELOAD=./nwuser.so:./nwmouse.so:./nwmovies.so (start nwn)"
+ echo ">>> ... etc"
+ echo ">>>"
+ echo ">>> Now when you start NWN again, all the extra modules should load successfully."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*
+