summarylogtreecommitdiffstats
path: root/nwn.install
diff options
context:
space:
mode:
authorSlashbunny2014-11-24 19:53:25 -0500
committerSlashbunny2014-11-24 19:53:25 -0500
commitde3dcfbe80e90c9856e4f2a1786bc3bc6f90751f (patch)
tree484f3033ec8c479e64846227efa12d0c2325a4d8 /nwn.install
parent0efca9af9aef8a89f248c249301466365714b686 (diff)
downloadaur-de3dcfbe80e90c9856e4f2a1786bc3bc6f90751f.tar.gz
Large refactoring of nwn-diamond PKGBUILD
* Modernize PKGBUILD (prepare, build, package functions) * All DVD operations and archive extractions now happen in prepare() * Patching only happens in prepare() * Update nwn addons to use new github source location * Quote all paths with variables * Add default key file, instructions during install on how to use it * Add key file to backup array * Move all addon compilation to build() function * Move all addon installation into custom _install_addons() function for clarity
Diffstat (limited to 'nwn.install')
-rw-r--r--nwn.install33
1 files changed, 12 insertions, 21 deletions
diff --git a/nwn.install b/nwn.install
index 9a4304d13759..70bd1d6904a1 100644
--- a/nwn.install
+++ b/nwn.install
@@ -1,24 +1,15 @@
-
post_install() {
- echo ">>> If you use software mixing on your sound card, uncomment the"
- echo ">>> first export statement in /usr/bin/nwn to make that work"
- echo ">>>"
- echo ">>> Some of the additional modules create .ini files the first time"
- echo ">>> they start. You may have to restart nwn a few times for it"
- echo ">>> load successfully. This is normal. Run 'nwn' from a terminal the"
- echo ">>> first few times until the game starts running correctly."
-}
-
-post_upgrade() {
- post_install $1
+ echo "Before running Neverwinter Nights, you must edit /opt/nwn/nwncdkey.ini"
+ echo " and enter the 3 CD keys that came with your NWN Diamond DVD"
+ echo ""
+
+ echo "Some of the additional linux modules create .ini files the first time"
+ echo " they start. You may have to run 'nwn' a few times for the game"
+ echo " load successfully. Run 'nwn' from a terminal initially so you can"
+ echo " inspect the output."
+ echo ""
+
+ echo "If you use software mixing on your sound card, uncomment the"
+ echo " first export statement in /usr/bin/nwn"
}
-pre_remove() {
- /bin/true
-}
-
-op=$1
-shift
-
-$op $*
-