summarylogtreecommitdiffstats
path: root/nwn.launcher
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit656757ae26ab4a1aa0f8acbfc12ad76137f99d28 (patch)
tree388c481614dcea503e2095649cb0dcd595bf23ef /nwn.launcher
downloadaur-656757ae26ab4a1aa0f8acbfc12ad76137f99d28.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
Diffstat (limited to 'nwn.launcher')
-rw-r--r--nwn.launcher29
1 files changed, 29 insertions, 0 deletions
diff --git a/nwn.launcher b/nwn.launcher
new file mode 100644
index 000000000000..6a38ff7b6058
--- /dev/null
+++ b/nwn.launcher
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+cd "/opt/nwn"
+
+# Uncomment to make SDL Sound work on Software Mixers
+#export SDL_AUDIODRIVER=esd
+export SDL_MOUSE_RELATIVE=0
+export SDL_VIDEO_X11_DGAMOUSE=0
+
+# Hardware Mouse Cursor
+export XCURSOR_PATH=/opt/nwn
+export XCURSOR_THEME=nwmouse
+
+# Enable AA on NVidia cards (/usr/share/doc/NVIDIA_GLX-1.0/README.txt)
+# 3 = 1.5 x 1.5 super sampling
+# 4 = 2x2 super sampling
+export __GL_FSAA_MODE=4
+
+# Add Miles Sound Codec to Library Path
+export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH
+
+# Per-User Settings Support, Hardware Mouse Cursor Support, Linux Movies Support, Client Side Chat Logging Support
+export LD_PRELOAD=./nwuser.so:./nwmouse.so:./nwmovies.so:./nwlogger.so
+
+# Run Neverwinter Nights
+./nwmain $*
+
+exit $?
+