summarylogtreecommitdiffstats
path: root/oci-cli.patch
diff options
context:
space:
mode:
authorAndrew O'Neill2021-08-15 21:14:37 -0400
committerAndrew O'Neill2021-08-15 21:14:37 -0400
commit5c19f6406d81639a7bfb51e1bb45cd51808a067c (patch)
treef348cdd75f47c1d3fd192acfee7990b1d85f99c1 /oci-cli.patch
parente893e09f8224cd14214ad4d0af15afc446a673f9 (diff)
downloadaur-5c19f6406d81639a7bfb51e1bb45cd51808a067c.tar.gz
Version bump
Diffstat (limited to 'oci-cli.patch')
-rw-r--r--oci-cli.patch33
1 files changed, 15 insertions, 18 deletions
diff --git a/oci-cli.patch b/oci-cli.patch
index 85b4fba5c286..2a6b3c15ff29 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,16 +1,16 @@
-diff -rupN oci-cli-2.26.4/setup.py oci-cli-2.26.4b/setup.py
---- oci-cli-2.26.4/setup.py 2021-07-27 14:09:09.000000000 -0400
-+++ oci-cli-2.26.4b/setup.py 2021-07-31 16:49:27.323401074 -0400
-@@ -30,23 +30,22 @@ with open_relative("README.rst") as f:
+diff -rupN oci-cli-3.0.0/setup.py oci-cli-3.0.0b/setup.py
+--- oci-cli-3.0.0/setup.py 2021-08-03 15:20:34.000000000 -0400
++++ oci-cli-3.0.0b/setup.py 2021-08-15 21:11:03.420019129 -0400
+@@ -29,23 +29,22 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.43.1',
+- 'oci==2.43.2',
- 'arrow==0.17.0',
+ 'oci',
+ 'arrow',
'certifi',
-- 'click==6.7',
+- 'click==7.0',
- 'configparser==4.0.2',
- 'cryptography>=3.2.1,<=3.4.7',
- 'jmespath==0.10.0',
@@ -37,15 +37,12 @@ diff -rupN oci-cli-2.26.4/setup.py oci-cli-2.26.4b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.26.4/src/oci_cli/cli_root.py oci-cli-2.26.4b/src/oci_cli/cli_root.py
---- oci-cli-2.26.4/src/oci_cli/cli_root.py 2021-07-27 14:09:09.000000000 -0400
-+++ oci-cli-2.26.4b/src/oci_cli/cli_root.py 2021-07-31 16:49:45.512918304 -0400
-@@ -307,7 +307,7 @@ For information on configuration, see ht
- @click.option('--profile',
- default=Sentinel(DEFAULT_PROFILE), show_default=False,
- help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')
--@click.option('--cli-rc-file', '--defaults-file',
-+@click.option('--cli-rc-file', '--defaults-file', 'defaults_file',
- default=cli_constants.CLI_RC_DEFAULT_LOCATION, show_default=True,
- is_eager=True, callback=eager_load_cli_rc_file,
- help='The path to the OCI CLI-specific configuration file, containing parameter default values and other configuration information such as command aliases and predefined queries. The --defaults-file option is deprecated and you should use the --cli-rc-file option instead.')
+@@ -90,7 +89,7 @@ setup(
+ packages=all_packages,
+ package_dir=package_dirs,
+ include_package_data=True,
+- python_requires='>=3.6',
++ python_requires='',
+ license="Universal Permissive License 1.0 or Apache License 2.0",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",