summarylogtreecommitdiffstats
path: root/openfoam.install
diff options
context:
space:
mode:
authorGeorge Eleftheriou2015-07-17 00:34:28 +0200
committerGeorge Eleftheriou2015-07-17 00:34:28 +0200
commita0b12f9a5546ddb898baa1d4527e35497abee7ec (patch)
tree0259629792891fe722e40953c7d1d15b09543de5 /openfoam.install
parente667a7260a317df2c8079263808cafbf5177656a (diff)
downloadaur-a0b12f9a5546ddb898baa1d4527e35497abee7ec.tar.gz
Minor fixes and modifications in PKGBUILD and .install file
Diffstat (limited to 'openfoam.install')
-rw-r--r--openfoam.install14
1 files changed, 14 insertions, 0 deletions
diff --git a/openfoam.install b/openfoam.install
index b37ae23a2c4d..286b28312809 100644
--- a/openfoam.install
+++ b/openfoam.install
@@ -1,5 +1,7 @@
+# arg 1: the new package version
post_install() {
echo "NOTE:"
+ echo ""
echo "This install of OpenFOAM does NOT include the"
echo "ThirdParty libraries from openfoam's website."
echo "It simply creates a stub OpenFOAM/ThirdParty"
@@ -14,4 +16,16 @@ post_install() {
echo "If you need other components of the ThirdParty bundle"
echo "it will have to be installed manually."
echo "See http://www.openfoam.com/download/source.php for details."
+ echo ""
+ echo "Don't forget to run the \"ofoam\" alias in order to"
+ echo "source the OpenFOAM environment (PATH + LD_LIBRARY_PATH)."
+ echo "This alias has been introduced in order to avoid"
+ echo "PATH clashes (e.g. other executables such as R from GNU R)"
+ echo ""
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
}