summarylogtreecommitdiffstats
path: root/openvpn.install
diff options
context:
space:
mode:
authorChris Lea2021-06-28 22:15:51 -0700
committerChris Lea2021-06-28 22:15:51 -0700
commit45483e08174cea8b6dd15f641f344a31c694fdb3 (patch)
tree7ca6f2c45967dbc6afc5c6315875ad0c7c3f6c79 /openvpn.install
parent12f4b403bf5d83a13b7cfbc13c736eb3239deaa1 (diff)
downloadaur-45483e08174cea8b6dd15f641f344a31c694fdb3.tar.gz
Make package mirror vanilla Arch Linux OpenVPN more closely.
- Update PKGBUILD to look as close as possible to the vanilla Arch OpenVPN. - Add additional packaging files. - This includes the patch to run as an unprivileged user.
Diffstat (limited to 'openvpn.install')
-rw-r--r--openvpn.install12
1 files changed, 12 insertions, 0 deletions
diff --git a/openvpn.install b/openvpn.install
new file mode 100644
index 000000000000..09ded1e5f121
--- /dev/null
+++ b/openvpn.install
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+post_upgrade() {
+ # return if old package version greater 2.5.0-1...
+ (( $(vercmp $2 '2.5.0-1') > 0 )) && return
+
+ echo ':: OpenVPN now uses a netlink interface for network configuration. The systemd'
+ echo " units start the process with a dedicated unprivileged user 'openvpn', with"
+ echo ' extra capabilities(7). The configuration should no longer drop privileges,'
+ echo " so remove 'user' and 'group' directives."
+ echo ' Scripts that require elevated privileges may need a workaround.'
+}