summarylogtreecommitdiffstats
path: root/optional-reqs.patch
diff options
context:
space:
mode:
authorMatthew Ellison2016-01-26 12:28:39 -0500
committerMatthew Ellison2016-01-26 12:28:39 -0500
commit38a1ff639a1bbbdae5d14c0db4e900f2fca9f781 (patch)
tree02082242036cf5adfb896c8f459576f38009364f /optional-reqs.patch
parent9a0e651e9af12a1c757f1e12c8db8e03aa4c97ac (diff)
downloadaur-38a1ff639a1bbbdae5d14c0db4e900f2fca9f781.tar.gz
Setuptools Requirements Patch
Removed requirements when built/installed on Python 3.4 or greater so distutils will not complain about argparse. Since Python 3.4, all requirements are included in the standard library.
Diffstat (limited to 'optional-reqs.patch')
-rw-r--r--optional-reqs.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/optional-reqs.patch b/optional-reqs.patch
new file mode 100644
index 000000000000..04999b37f62c
--- /dev/null
+++ b/optional-reqs.patch
@@ -0,0 +1,12 @@
+--- ./setup.py.old 2016-01-26 12:18:09.169870846 -0500
++++ ./setup.py 2016-01-26 12:21:13.526724075 -0500
+@@ -12,6 +12,9 @@
+
+
+ def get_install_requirements(path):
++ import sys
++ if sys.version_info[0] >= 3 and sys.version_info[1] >= 4:
++ return []
+ content = open(os.path.join(__location__, path)).read()
+ return [req for req in content.split('\\n') if req != '']
+