summarylogtreecommitdiffstats
path: root/patch-src_configure_ac.patch
diff options
context:
space:
mode:
authorUffe Jakobsen2015-06-22 23:55:50 +0200
committerUffe Jakobsen2015-06-22 23:55:50 +0200
commitc01c2da078123dbf3afab8c297d5188709395f9b (patch)
tree528395e809372913ae79b8b2e5e2a75a4dab9eb4 /patch-src_configure_ac.patch
downloadaur-c01c2da078123dbf3afab8c297d5188709395f9b.tar.gz
Initial import
Diffstat (limited to 'patch-src_configure_ac.patch')
-rw-r--r--patch-src_configure_ac.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/patch-src_configure_ac.patch b/patch-src_configure_ac.patch
new file mode 100644
index 000000000000..88a04c71ab35
--- /dev/null
+++ b/patch-src_configure_ac.patch
@@ -0,0 +1,45 @@
+--- src/configure.ac.orig 2015-03-15 15:48:39.682585072 +0100
++++ src/configure.ac 2015-03-15 15:50:24.530767124 +0100
+@@ -42,6 +42,31 @@
+ exit 1
+ fi
+
++ if ! test $PYEXE
++ then
++ PYEXE=$(which python)
++ if ! test ${PYEXE}
++ then
++ PYEXE=$(which python3)
++ fi
++ fi
++ echo $PYEXE
++
++ if ! test $PYDEV
++ then
++ for INCL in $(python-config --includes)
++ do
++ echo $INCL
++ INCL=$(echo "${INCL}" | sed 's:^-I::g')
++ echo $INCL
++ if test -f "${INCL}/Python.h"
++ then
++ PYDEV="${INCL}"
++ break;
++ fi;
++ done
++ fi
++
+ if ! test $PYDEV
+ then
+ PYDEV="/usr/include/python$(python -V 2>&1 | awk '{print $2}' | cut -d'.' -f1,2)"
+@@ -53,8 +78,8 @@
+ then
+ dnl This is a hack to get a valid python library path
+ echo "import sys" > pylib.py
+- echo "for path in sys.path: print path" >> pylib.py
+- PYLIB="$(python pylib.py | grep -e '-packages$' | head -1)"
++ echo "for path in sys.path: print(path)" >> pylib.py
++ PYLIB="$(${PYEXE} pylib.py | grep -e '-packages$' | head -1)"
+ rm -f pylib.py
+ fi
+