summarylogtreecommitdiffstats
path: root/patch
diff options
context:
space:
mode:
authorqontinuum2021-07-04 10:54:22 +0200
committerqontinuum2021-07-04 10:54:22 +0200
commitb90bfd3c8880a85aca9513375ab11495f04f0a0b (patch)
treeccf1339de0ae85c7d160ceb0853d5e43708af106 /patch
parent9efbe83facb9808cf289de6dfc550326f617c5b6 (diff)
downloadaur-b90bfd3c8880a85aca9513375ab11495f04f0a0b.tar.gz
Disable compilation of useless static library and echobot
Diffstat (limited to 'patch')
-rw-r--r--patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/patch b/patch
new file mode 100644
index 000000000000..f2b06bdd181b
--- /dev/null
+++ b/patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d781dfe..07aace3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -29,7 +29,7 @@ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_LIB_CFLAGS} -Werror -Wall -Wno-unuse
+
+ # libtelebot
+ ADD_LIBRARY(${PROJECT_NAME} SHARED ${SRCS})
+-ADD_LIBRARY(${PROJECT_NAME}_static STATIC ${SRCS})
++# ADD_LIBRARY(${PROJECT_NAME}_static STATIC ${SRCS})
+ TARGET_LINK_LIBRARIES(${PROJECT_NAME} ${PKGS_LDFLAGS})
+ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES VERSION ${VERSION})
+
+@@ -37,7 +37,7 @@ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES VERSION ${VERSION})
+ CONFIGURE_FILE(telebot.pc.in telebot.pc @ONLY)
+
+ # echobot (test)
+-ADD_SUBDIRECTORY(test)
++# ADD_SUBDIRECTORY(test)
+
+ # CMake Policy (CMP0002)
+ # The logical name of executable and library targets