summarylogtreecommitdiffstats
path: root/pennywise.sh
diff options
context:
space:
mode:
authorzxp198210052023-07-18 10:09:07 +0800
committerzxp198210052023-07-18 10:09:07 +0800
commit9d403b4395adff8427e44588b01bf21714dafcc0 (patch)
tree8ff8a428affa0ca7daf3f5cd36b52708200def06 /pennywise.sh
parent9ce9c7a5d0563bc38e9629fbd78f4f5efe461498 (diff)
downloadaur-9d403b4395adff8427e44588b01bf21714dafcc0.tar.gz
optimized PKGBUILD
Diffstat (limited to 'pennywise.sh')
-rw-r--r--pennywise.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/pennywise.sh b/pennywise.sh
new file mode 100644
index 000000000000..b57cb80742cd
--- /dev/null
+++ b/pennywise.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron5
+_ASAR="/opt/pennywise/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file