summarylogtreecommitdiffstats
path: root/pgo.patch
diff options
context:
space:
mode:
authorBjörn Bidar2019-01-09 06:34:07 +0100
committerBjörn Bidar2019-01-09 06:40:06 +0100
commite1ea7c08c24430e306d15861c53ee47b45d8348a (patch)
tree05ddbbb0c096225696e5370169303728d90f3deb /pgo.patch
parent6d7c34e1b374b8a19342d651ae8291a6a1fde8b6 (diff)
downloadaur-e1ea7c08c24430e306d15861c53ee47b45d8348a.tar.gz
urel
- fix pgo build with gcc (and 8.x to that extend) - apply patches from Jan Hubička and Fedora to fix pgo builds - disable-elfhack on pgo builds (mimic Fedora) - remove gcc7 workaround - clean up mentions of experimental wayland support as its enabled by default - clean up PKGBUILD and set CC just one
Diffstat (limited to 'pgo.patch')
-rw-r--r--pgo.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/pgo.patch b/pgo.patch
new file mode 100644
index 000000000000..20eb98de30a9
--- /dev/null
+++ b/pgo.patch
@@ -0,0 +1,29 @@
+diff -up firefox-64.0/build/unix/mozconfig.unix.pgo firefox-64.0/build/unix/mozconfig.unix
+--- firefox-64.0/build/unix/mozconfig.unix.pgo 2019-01-03 15:23:16.792980384 +0100
++++ firefox-64.0/build/unix/mozconfig.unix 2019-01-03 15:24:29.978693550 +0100
+@@ -6,6 +6,15 @@ if [ -n "$FORCE_GCC" ]; then
+ CC="$TOOLTOOL_DIR/gcc/bin/gcc"
+ CXX="$TOOLTOOL_DIR/gcc/bin/g++"
+
++ if [ -n "$MOZ_PGO" ]; then
++ if [ -z "$USE_ARTIFACT" ]; then
++ ac_add_options --enable-lto
++ fi
++ export AR="$topsrcdir/gcc/bin/gcc-ar"
++ export NM="$topsrcdir/gcc/bin/gcc-nm"
++ export RANLIB="$topsrcdir/gcc/bin/gcc-ranlib"
++ fi
++
+ # We want to make sure we use binutils and other binaries in the tooltool
+ # package.
+ mk_add_options "export PATH=$TOOLTOOL_DIR/gcc/bin:$PATH"
+diff -up firefox-64.0/extensions/spellcheck/src/moz.build.pgo firefox-64.0/extensions/spellcheck/src/moz.build
+--- firefox-64.0/extensions/spellcheck/src/moz.build.pgo 2018-12-07 03:56:27.000000000 +0100
++++ firefox-64.0/extensions/spellcheck/src/moz.build 2019-01-03 15:21:32.793385074 +0100
+@@ -28,3 +28,5 @@ EXPORTS.mozilla += [
+
+ if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
+ CXXFLAGS += ['-Wno-error=shadow']
++
++CXXFLAGS += ['-fno-devirtualize']
+\ No newline at end of file