summarylogtreecommitdiffstats
path: root/phc-intel.sh
diff options
context:
space:
mode:
authordreieck2023-03-04 16:06:10 +0100
committerdreieck2023-03-04 16:06:10 +0100
commitbf973816302af8db54652313a4d0a6deceeae8ec (patch)
tree56f1023b53a080b693148923bc1ad1891c7115ed /phc-intel.sh
parenta174aebeebbedd7120f180e973a59e3729e59b22 (diff)
downloadaur-bf973816302af8db54652313a4d0a6deceeae8ec.tar.gz
* `phc-intel.sh`: Added a `--version` option,
* `PKGBUILD`: Setting `$pkgver` via `pkgver()` from `./phc-intel.sh --version`.
Diffstat (limited to 'phc-intel.sh')
-rwxr-xr-xphc-intel.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/phc-intel.sh b/phc-intel.sh
index 01236845c348..a62ad5839c56 100755
--- a/phc-intel.sh
+++ b/phc-intel.sh
@@ -2,6 +2,7 @@
## This file is licensed under the GNU General Public License, version 2.
+VERSION=0.4.0
_conf='/etc/default/phc-intel'
msg() {
@@ -90,8 +91,12 @@ case "$1" in
"$0" stop
;;
+ --version)
+ printf '%s\n' "${VERSION}"
+ ;;
+
*)
- echo "usage: $0 {start|stop|status|set|force-set|reset}"
+ echo "usage: $0 {start|stop|status|set|force-set|reset|--version}"
;;
esac