summarylogtreecommitdiffstats
path: root/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
diff options
context:
space:
mode:
authorJulianne H2023-01-05 13:12:24 +0100
committerJulianne H2023-01-05 13:12:24 +0100
commit690bf2716c405d7827bee0c37b000b42acc36c37 (patch)
tree5608abd0a1326e4d7c6ffc7ef0de7d8712f3adc0 /pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
parentc7e548fb905b0bed0288801eb6000999959cbe45 (diff)
downloadaur-690bf2716c405d7827bee0c37b000b42acc36c37.tar.gz
Update: 1.26.1
Diffstat (limited to 'pl-0002-makepkg-Remove-extraneous-compiler-flags.patch')
-rw-r--r--pl-0002-makepkg-Remove-extraneous-compiler-flags.patch19
1 files changed, 10 insertions, 9 deletions
diff --git a/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch b/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
index 7c7cf0bce3b9..4eac9e773328 100644
--- a/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
+++ b/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
@@ -1,25 +1,26 @@
-From f05087e0d92d6312294b06f026ef8a19fac4eac2 Mon Sep 17 00:00:00 2001
+From d28e965509fdce0c90389a99a096f2d1ae879e8b Mon Sep 17 00:00:00 2001
From: KokaKiwi <kokakiwi+git@kokakiwi.net>
Date: Sat, 17 Sep 2022 16:27:17 +0200
Subject: [PATCH 2/2] makepkg: Remove extraneous compiler flags
---
- lib/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ lib/CMakeLists.txt | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
-index 4d593ff..585fdb2 100644
+index f801e3e..1a36e9a 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
-@@ -34,7 +34,7 @@ add_library(libpl ${LIBRARY_TYPE}
+@@ -34,8 +34,7 @@ add_library(libpl ${LIBRARY_TYPE}
source/pl/lib/std/hash.cpp
)
--target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wno-unknown-pragmas)
+-target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas)
+-
+target_compile_options(libpl PRIVATE -Wno-unknown-pragmas)
target_include_directories(libpl PUBLIC include)
- target_link_libraries(libpl PUBLIC fmt::fmt intervaltree)
- set_property(TARGET libpl PROPERTY POSITION_INDEPENDENT_CODE ON)
+ target_link_libraries(libpl PRIVATE fmt::fmt-header-only)
+ target_link_libraries(libpl PUBLIC intervaltree)
--
-2.38.1
+2.39.0