summarylogtreecommitdiffstats
path: root/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
diff options
context:
space:
mode:
authorKokaKiwi2023-04-04 15:34:45 +0200
committerKokaKiwi2023-04-04 15:34:45 +0200
commitf2757dfe17084b8bf64567830f499604c2a57b30 (patch)
tree7bf2e0b9842ddafe107a26d1157c82bf28e460e9 /pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
parent3df7965147d80a70413fb5dad794b0d4d0159e22 (diff)
downloadaur-f2757dfe17084b8bf64567830f499604c2a57b30.tar.gz
upgpkg: imhex 1.28.0-1
upstream release
Diffstat (limited to 'pl-0002-makepkg-Remove-extraneous-compiler-flags.patch')
-rw-r--r--pl-0002-makepkg-Remove-extraneous-compiler-flags.patch28
1 files changed, 17 insertions, 11 deletions
diff --git a/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch b/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
index ea39a53742bf..52b5342687aa 100644
--- a/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
+++ b/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
@@ -1,26 +1,32 @@
-From b6b11e11956f02660fc67836ec718fd96c185abd Mon Sep 17 00:00:00 2001
+From 457106b700371e66d701efd6668d0f59083c5925 Mon Sep 17 00:00:00 2001
From: KokaKiwi <kokakiwi+git@kokakiwi.net>
Date: Sat, 17 Sep 2022 16:27:17 +0200
Subject: [PATCH 2/2] makepkg: Remove extraneous compiler flags
---
- lib/CMakeLists.txt | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
+ lib/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
-index f801e3e..1a36e9a 100644
+index e1a1384..14eb593 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
-@@ -34,8 +34,7 @@ add_library(libpl ${LIBRARY_TYPE}
- source/pl/lib/std/hash.cpp
+@@ -34,7 +34,7 @@ add_library(libpl ${LIBRARY_TYPE}
+ source/pl/lib/std/random.cpp
)
--target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas)
--
-+target_compile_options(libpl PRIVATE -Wno-unknown-pragmas)
+-target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas -Wno-stringop-overread -Wno-stringop-overflow -Wno-array-bounds)
++target_compile_options(libpl PRIVATE -Wno-unknown-pragmas -Wno-stringop-overread -Wno-stringop-overflow -Wno-array-bounds)
+
target_include_directories(libpl PUBLIC include)
target_link_libraries(libpl PRIVATE fmt::fmt-header-only)
- target_link_libraries(libpl PUBLIC intervaltree)
+@@ -46,4 +46,4 @@ set_target_properties(libpl PROPERTIES PREFIX "")
+
+ if (LIBPL_SHARED_LIBRARY)
+ install(TARGETS libpl DESTINATION lib)
+-endif ()
+\ No newline at end of file
++endif ()
--
-2.39.1
+2.40.0