summarylogtreecommitdiffstats
path: root/poe-fix.patch
diff options
context:
space:
mode:
authorLars Norberg2018-03-17 13:55:06 +0100
committerLars Norberg2018-03-17 13:55:06 +0100
commit714c4f1d62f4822ff6397184b225396cefb74f1b (patch)
treef6e7eb4631dd8c961a1202d19404286f722879c8 /poe-fix.patch
parent66fe5b7a0edfe783b1d38b769b9248be0e5a594b (diff)
downloadaur-714c4f1d62f4822ff6397184b225396cefb74f1b.tar.gz
added Path of Exile DX11 patch, see PKGBUILD comments for info
Diffstat (limited to 'poe-fix.patch')
-rw-r--r--poe-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/poe-fix.patch b/poe-fix.patch
new file mode 100644
index 000000000000..c2dea6ddbc73
--- /dev/null
+++ b/poe-fix.patch
@@ -0,0 +1,11 @@
+--- a/dlls/ole32/compobj.c
++++ b/dlls/ole32/compobj.c
+@@ -3213,6 +3213,7 @@
+ {
+ MULTI_QI multi_qi = { iid };
+ HRESULT hres;
++ CoInitialize(NULL);
+
+ TRACE("(rclsid=%s, pUnkOuter=%p, dwClsContext=%08x, riid=%s, ppv=%p)\n", debugstr_guid(rclsid),
+ pUnkOuter, dwClsContext, debugstr_guid(iid), ppv);
+