summarylogtreecommitdiffstats
path: root/pokemonrevolution
diff options
context:
space:
mode:
authorTids2016-03-27 22:14:05 +0200
committerTids2016-03-27 22:14:05 +0200
commit2067d7bfc116c7509f77cb4cb4042adad3cf08b6 (patch)
treec558a05a9919ef146c8683f545f7ac5505132411 /pokemonrevolution
downloadaur-2067d7bfc116c7509f77cb4cb4042adad3cf08b6.tar.gz
switch from pokemon-revolution-online to *-bin ; we only use the binary version since there is no source code
Diffstat (limited to 'pokemonrevolution')
-rw-r--r--pokemonrevolution18
1 files changed, 18 insertions, 0 deletions
diff --git a/pokemonrevolution b/pokemonrevolution
new file mode 100644
index 000000000000..4105fd137028
--- /dev/null
+++ b/pokemonrevolution
@@ -0,0 +1,18 @@
+#! /bin/bash
+## helper script to run PRO.
+GAMEDIR="GAMEDIRNAMESETBYPKGBUILD"
+GAMEBINARY="GAMEBINARYNAMESETBYPKGBUILD"
+
+## enforce opengl to workaround a bug that makes the game start in direct3d mode on linux -> "-force-opengl"
+OPTIONS="-force-opengl"
+
+echo -e "--> \"${GAMEDIR}/${GAMEBINARY}\" ${OPTIONS} ${@}"
+echo -e "..."
+
+## to workaround an error that the game can't find some importtant files on some systems, we cd to the game root first
+cd "${GAMEDIR}"
+
+## start the game!
+"${GAMEDIR}/${GAMEBINARY}" ${OPTIONS} ${@}
+
+exit \ No newline at end of file