summarylogtreecommitdiffstats
path: root/pokemonrevolution
diff options
context:
space:
mode:
authorTids2017-01-23 23:42:06 +0100
committerTids2017-01-23 23:42:06 +0100
commitaf8f89dc8ad5c682b0eca97cb55be9dc4f7b02bd (patch)
tree381d4749cdd06a5942be97c3ecd7f02f1bd44fe6 /pokemonrevolution
parent70c96b3179c504c537392dc3cf16a5e96ce4e5ac (diff)
downloadaur-af8f89dc8ad5c682b0eca97cb55be9dc4f7b02bd.tar.gz
switch to -force-glcore for better GL support
Diffstat (limited to 'pokemonrevolution')
-rw-r--r--pokemonrevolution7
1 files changed, 4 insertions, 3 deletions
diff --git a/pokemonrevolution b/pokemonrevolution
index 4105fd137028..bba2bd5d9df5 100644
--- a/pokemonrevolution
+++ b/pokemonrevolution
@@ -3,8 +3,9 @@
GAMEDIR="GAMEDIRNAMESETBYPKGBUILD"
GAMEBINARY="GAMEBINARYNAMESETBYPKGBUILD"
-## enforce opengl to workaround a bug that makes the game start in direct3d mode on linux -> "-force-opengl"
-OPTIONS="-force-opengl"
+## enforce opengl to workaround a bug that makes the game start in direct3d mode on linux -> "-force-glcore"
+## https://docs.unity3d.com/Manual/OpenGLCoreDetails.html
+OPTIONS="-force-glcore"
echo -e "--> \"${GAMEDIR}/${GAMEBINARY}\" ${OPTIONS} ${@}"
echo -e "..."
@@ -15,4 +16,4 @@ cd "${GAMEDIR}"
## start the game!
"${GAMEDIR}/${GAMEBINARY}" ${OPTIONS} ${@}
-exit \ No newline at end of file
+exit