summarylogtreecommitdiffstats
path: root/port_to_kf5.patch
diff options
context:
space:
mode:
authormaz-12015-12-03 17:23:00 +0800
committermaz-12015-12-03 17:23:00 +0800
commit5e0d66b874ef69bda158159b0414f138e914d61a (patch)
treec79228cb5d6cc89a6bcfaecbe31a39d018a8b13b /port_to_kf5.patch
parenta5d1a0e1a9e8da9444b81075b329fce1d2158d84 (diff)
downloadaur-5e0d66b874ef69bda158159b0414f138e914d61a.tar.gz
fix
Diffstat (limited to 'port_to_kf5.patch')
-rw-r--r--port_to_kf5.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/port_to_kf5.patch b/port_to_kf5.patch
index 2a737c1af316..03d4967b7773 100644
--- a/port_to_kf5.patch
+++ b/port_to_kf5.patch
@@ -19,7 +19,7 @@ diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+include(FeatureSummary)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets)
-+find_package(KF5 REQUIRED COMPONENTS KDELibs4Support Archive NewStuff) #
++find_package(KF5 REQUIRED COMPONENTS KDELibs4Support Archive NewStuff I18n)
add_subdirectory(src)
add_subdirectory(po)
@@ -43,7 +43,7 @@ diff -Naur a/src/CMakeLists.txt b/src/CMakeLists.txt
+add_library(kcm_servicemenus MODULE ${kcm_servicemenus-sources})
-target_link_libraries(kcm_servicemenus ${KDE4_KIO_LIBS} ${KDE4_KIO_LIBS} ${KDE4_KNEWSTUFF2_LIBS})
-+target_link_libraries(kcm_servicemenus KF5::KDELibs4Support KF5::Archive KF5::NewStuff) #
++target_link_libraries(kcm_servicemenus KF5::KDELibs4Support KF5::Archive KF5::NewStuff KF5::I18n)
install(TARGETS kcm_servicemenus DESTINATION ${PLUGIN_INSTALL_DIR} )
@@ -77,7 +77,7 @@ diff -Naur a/src/sm.cpp b/src/sm.cpp
#include <kmessagebox.h>
#include <kstandarddirs.h>
#include <ktar.h>
-@@ -58,7 +59,10 @@
+@@ -58,7 +59,13 @@
#include "sm.h"
@@ -86,6 +86,9 @@ diff -Naur a/src/sm.cpp b/src/sm.cpp
+#include <KUrl>
+#include <KIcon>
+#include <KConfigGroup>
++
++#define TRANSLATION_DOMAIN "kcm_servicemenus"
++#include <klocalizedstring.h>
//------------------------------------------------------------------------------
//--- init ---------------------------------------------------------------------