aboutsummarylogtreecommitdiffstats
path: root/pre-commit.sh
diff options
context:
space:
mode:
authorDany Marcoux2016-06-14 21:33:20 +0200
committerDany Marcoux2016-06-14 22:34:05 +0200
commitd57d31f9ad3685911fe984700811a16b5538d85c (patch)
tree333b62da1c23df37f6a784bab38a578e7b8997ca /pre-commit.sh
parentd0f7b31d9543ee5627173ec99f3a09ca1982303f (diff)
downloadaur-d57d31f9ad3685911fe984700811a16b5538d85c.tar.gz
Pre-release tag-ag 1.0.0-3
Setup git pre-commit hook to generate .SRCINFO file and add it to the commit if it changed
Diffstat (limited to 'pre-commit.sh')
-rwxr-xr-xpre-commit.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/pre-commit.sh b/pre-commit.sh
new file mode 100755
index 000000000000..1cfdd8f132b4
--- /dev/null
+++ b/pre-commit.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+# git pre-commit hook: Generate the .SRCINFO file and add it to the commit if it changed
+
+# Generate the .SRCINFO file based on the PKGBUILD file
+mksrcinfo
+
+# Check if the .SRCINFO file changed
+if [ -n "$(git diff --name-only | grep ^.SRCINFO$)" ]; then
+ printf "Updated .SRCINFO file\n"
+ git diff .SRCINFO
+ git add .SRCINFO
+ printf "\nAdded .SRCINFO file to the commit\n"
+fi