summarylogtreecommitdiffstats
path: root/prepare4uploadpkg.sh
diff options
context:
space:
mode:
authorJohn A Ginis2017-12-08 18:07:40 +0200
committerJohn A Ginis2017-12-08 18:07:40 +0200
commit7ba7ae62b8d24da1eb1ce6cd670ff55491dc465d (patch)
tree0d15ef5f6295eb3816e58a8619637d0e71c48848 /prepare4uploadpkg.sh
parent32847ba7c74bf136945944d4c29752f3c2219b62 (diff)
downloadaur-7ba7ae62b8d24da1eb1ce6cd670ff55491dc465d.tar.gz
New git commit
Diffstat (limited to 'prepare4uploadpkg.sh')
-rwxr-xr-xprepare4uploadpkg.sh8
1 files changed, 6 insertions, 2 deletions
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
index 934309fc5e6d..ac82dfe5b1e5 100755
--- a/prepare4uploadpkg.sh
+++ b/prepare4uploadpkg.sh
@@ -1,8 +1,12 @@
#!/usr/bin/env bash
+makepkg --nobuild --skipinteg
+
+rm -rf src/ conky*
+
namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
-git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
-git commit -am "New package commit" || exit 1
+git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
+git commit -am "New git commit" || exit 1
git push --set-upstream origin master || exit 1
read -p "Press [Enter] key to exit..."