summarylogtreecommitdiffstats
path: root/publish.sh
diff options
context:
space:
mode:
authorA.I2020-03-29 16:23:35 +0800
committerA.I2020-03-29 16:50:14 +0800
commitba9ce739e4ab5433a460c199066be299a660eeb0 (patch)
treef53b0851685f65e404ef6f8734eb5771976e3b30 /publish.sh
parent3c14772912c9097504a7d5f4abe040492fab5c54 (diff)
downloadaur-ba9ce739e4ab5433a460c199066be299a660eeb0.tar.gz
prepare for batch update
Diffstat (limited to 'publish.sh')
-rw-r--r--publish.sh23
1 files changed, 23 insertions, 0 deletions
diff --git a/publish.sh b/publish.sh
new file mode 100644
index 000000000000..87fbf23943b2
--- /dev/null
+++ b/publish.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env bash
+
+scripts=(sc tc j)
+widths=(compressed condensed extended normal wide)
+
+git commit --allow-empty "update package"
+for script in "${scripts[@]}"
+do
+ for width in "${widths[@]}"
+ do
+ pkgname="glow-sans-${script}-${width}"
+ echo "updating $pkgname"
+ sed -i -e "s/PH_SCRIPT/${script}/g" PKGBUILD
+ sed -i -e "s/PH_WIDTH/${width}/g" PKGBUILD
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ git add .
+ git commit -m "updates $pkgname"
+ git remote set-url aur "ssh://aur@aur.archlinux.org/$pkgname"
+ git push aur master
+ git reset --hard HEAD~1
+ done
+done