summarylogtreecommitdiffstats
path: root/pybind11.patch
diff options
context:
space:
mode:
authorAlex Hirzel2022-12-09 15:50:35 -0500
committerAlex Hirzel2022-12-09 15:50:35 -0500
commit09c424124639d32d816d41ff2a4b7bf79328846b (patch)
tree74ad528977b144fe826748974f28c4f5945bc21f /pybind11.patch
parent6b92681001b6751d7a32530b9103ab702a05277b (diff)
downloadaur-09c424124639d32d816d41ff2a4b7bf79328846b.tar.gz
clean up dependencies where possible
Diffstat (limited to 'pybind11.patch')
-rw-r--r--pybind11.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/pybind11.patch b/pybind11.patch
new file mode 100644
index 000000000000..33c5e2965ad6
--- /dev/null
+++ b/pybind11.patch
@@ -0,0 +1,13 @@
+diff --git a/src/ext/CMakeLists.txt b/src/ext/CMakeLists.txt
+index d90636a9..8197f0d3 100644
+--- a/src/ext/CMakeLists.txt
++++ b/src/ext/CMakeLists.txt
+@@ -80,7 +80,7 @@ add_subdirectory(EASTL)
+ target_link_libraries(luisa-compute-ext PUBLIC EASTL)
+
+ if (LUISA_COMPUTE_ENABLE_PYTHON)
+- add_subdirectory(pybind11)
++ find_package(pybind11 REQUIRED)
+ endif ()
+
+ if (LUISA_COMPUTE_ENABLE_ISPC OR LUISA_COMPUTE_ENABLE_LLVM)