summarylogtreecommitdiffstats
path: root/python-2.6-dbm.patch
diff options
context:
space:
mode:
authorChristopher Arndt2015-06-21 01:38:46 +0200
committerChristopher Arndt2015-06-21 01:38:46 +0200
commit7cb924d51eb667dcc750ce1c491fa9aa1a411077 (patch)
tree9800ef914697eda2bb83682076096e4a0e85b6ce /python-2.6-dbm.patch
downloadaur-7cb924d51eb667dcc750ce1c491fa9aa1a411077.tar.gz
Initial import of python26 package
Diffstat (limited to 'python-2.6-dbm.patch')
-rw-r--r--python-2.6-dbm.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/python-2.6-dbm.patch b/python-2.6-dbm.patch
new file mode 100644
index 000000000000..369db61df9e6
--- /dev/null
+++ b/python-2.6-dbm.patch
@@ -0,0 +1,17 @@
+--- setup.py.orig 2013-01-10 08:41:07.226990643 +0100
++++ setup.py 2013-01-10 08:51:14.641536855 +0100
+@@ -1122,12 +1122,8 @@
+
+ # The standard Unix dbm module:
+ if platform not in ['cygwin']:
+- if find_file("ndbm.h", inc_dirs, []) is not None:
+- # Some systems have -lndbm, others don't
+- if self.compiler.find_library_file(lib_dirs, 'ndbm'):
+- ndbm_libs = ['ndbm']
+- else:
+- ndbm_libs = []
++ if find_file("ndbm.h", inc_dirs, []) and self.compiler.find_library_file(lib_dirs, 'ndbm'):
++ ndbm_libs = ['ndbm']
+ exts.append( Extension('dbm', ['dbmmodule.c'],
+ define_macros=[('HAVE_NDBM_H',None)],
+ libraries = ndbm_libs ) )