summarylogtreecommitdiffstats
path: root/python-bcrypt-allow-subinterpreters.patch
diff options
context:
space:
mode:
authorBazaah2024-03-18 14:33:40 +0000
committerBazaah2024-03-23 10:36:24 +0000
commit8576de36db079548db41a5b170e8783a6b98ec3c (patch)
tree453018182265068a73f31922d5942c77d12c7414 /python-bcrypt-allow-subinterpreters.patch
parent246af22b29342b3a85fe989f2904f2721e8a2b12 (diff)
downloadaur-8576de36db079548db41a5b170e8783a6b98ec3c.tar.gz
repo: add python-bcrypt patches
- python-bcrypt-allow-subinterpreters.patch - python-bcrypt-prefix-ceph.patch Together, these allow us to build a renamed python-bcrypt package, as ceph_bcrypt. This will allow us to bypass the thorny pyo3 issues we have with various mgr modules exploding at runtime. References: https://github.com/bazaah/aur-ceph/issues/20
Diffstat (limited to 'python-bcrypt-allow-subinterpreters.patch')
-rw-r--r--python-bcrypt-allow-subinterpreters.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/python-bcrypt-allow-subinterpreters.patch b/python-bcrypt-allow-subinterpreters.patch
new file mode 100644
index 000000000000..060532898f5b
--- /dev/null
+++ b/python-bcrypt-allow-subinterpreters.patch
@@ -0,0 +1,13 @@
+diff --git a/src/_bcrypt/Cargo.toml b/src/_bcrypt/Cargo.toml
+index a9c7f7c..02317c8 100644
+--- a/src/_bcrypt/Cargo.toml
++++ b/src/_bcrypt/Cargo.toml
+@@ -6,7 +6,7 @@ edition = "2018"
+ publish = false
+
+ [dependencies]
+-pyo3 = { version = "0.20.0", features = ["abi3"] }
++pyo3 = { git = "https://git.st8l.com/luxolus/pyo3", tag = "v0.20.3-subint+1", features = ["abi3", "unsafe-allow-subinterpreters"] }
+ bcrypt = "0.15"
+ bcrypt-pbkdf = "0.10.0"
+ base64 = "0.21.5"