summarylogtreecommitdiffstats
path: root/python-config-32.patch
diff options
context:
space:
mode:
authorBehnam Momeni2022-08-05 17:22:21 +0430
committerBehnam Momeni2022-08-05 20:28:20 +0430
commita2383dae3686ad1d63a6cb104b16debd1f9d5624 (patch)
treef3c7df4b0f09a12fe5ccc7c9791ac7322c255aa6 /python-config-32.patch
parent30f53a842b40c1c2c8237878b42fd5824927cd0f (diff)
downloadaur-a2383dae3686ad1d63a6cb104b16debd1f9d5624.tar.gz
Upgrade to 3.10.5
Diffstat (limited to 'python-config-32.patch')
-rw-r--r--python-config-32.patch20
1 files changed, 11 insertions, 9 deletions
diff --git a/python-config-32.patch b/python-config-32.patch
index f9a71f9c3a8e..aff834019361 100644
--- a/python-config-32.patch
+++ b/python-config-32.patch
@@ -1,7 +1,7 @@
-diff -Naur Python-3.7.0.orig/Makefile.pre.in Python-3.7.0/Makefile.pre.in
---- Python-3.7.0.orig/Makefile.pre.in 2018-08-06 11:07:55.945672075 -0400
-+++ Python-3.7.0/Makefile.pre.in 2018-08-06 11:14:58.927173361 -0400
-@@ -1206,13 +1206,13 @@
+diff -ruN Python-3.10.5/Makefile.pre.in Python-3.10.5.new/Makefile.pre.in
+--- Python-3.10.5/Makefile.pre.in 2022-06-06 16:23:30.000000000 +0430
++++ Python-3.10.5.new/Makefile.pre.in 2022-08-05 17:00:11.809493442 +0430
+@@ -1372,15 +1372,15 @@
fi
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
-if test "$(VERSION)" != "$(LDVERSION)"; then \
@@ -11,14 +11,16 @@ diff -Naur Python-3.7.0.orig/Makefile.pre.in Python-3.7.0/Makefile.pre.in
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)$(EXE)-config python$(VERSION)$(EXE)-config); \
rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
+ rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION)-embed.pc; \
+ (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION)-embed.pc python-$(LDVERSION)-embed.pc); \
fi
-rm -f $(DESTDIR)$(BINDIR)/python3-config
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE)-config python3-config)
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python3.pc)
- -rm -f $(DESTDIR)$(BINDIR)/idle3
-@@ -1422,12 +1422,12 @@
+ -rm -f $(DESTDIR)$(LIBPC)/python3-embed.pc
+@@ -1639,12 +1639,12 @@
@ # is not available in configure
sed -e "s,@EXENAME@,$(BINDIR)/python$(LDVERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config.py
@ # Replace makefile compat. variable references with shell script compat. ones; $(VAR) -> ${VAR}
@@ -33,7 +35,7 @@ diff -Naur Python-3.7.0.orig/Makefile.pre.in Python-3.7.0/Makefile.pre.in
fi
-@@ -1486,7 +1486,7 @@
+@@ -1726,7 +1726,7 @@
$(INSTALL_SCRIPT) $(srcdir)/Modules/makesetup $(DESTDIR)$(LIBPL)/makesetup
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
@@ -42,12 +44,12 @@ diff -Naur Python-3.7.0.orig/Makefile.pre.in Python-3.7.0/Makefile.pre.in
@if [ -s Modules/python.exp -a \
"`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
echo; echo "Installing support files for building shared extension modules on AIX:"; \
-@@ -1693,7 +1693,7 @@
+@@ -1937,7 +1937,7 @@
config.cache config.log pyconfig.h Modules/config.c
-rm -rf build platform
-rm -rf $(PYTHONFRAMEWORKDIR)
- -rm -f python-config.py python-config
+ -rm -f python-config.py python$(EXE)-config
- -rm -f profile-gen-stamp profile-clean-stamp
# Make things extra clean, before making a distribution:
+ # remove all generated files, even Makefile[.pre]