summarylogtreecommitdiffstats
path: root/python-install-flags.patch
diff options
context:
space:
mode:
authorAlexander Paetzelt2020-03-09 17:04:36 +0100
committerAlexander Paetzelt2020-03-09 17:04:36 +0100
commit3b9027f01b2c8f6b463cafaece532a429517669d (patch)
treee8b5353a025c489ccd246481aeaad544faf4aad7 /python-install-flags.patch
parent5eaa823267a2a72e204e7043f73fc1cec00e3096 (diff)
downloadaur-3b9027f01b2c8f6b463cafaece532a429517669d.tar.gz
Include changes made in [extra] 'kismet' package
* clean up dependencies * fix stripping through makepkg
Diffstat (limited to 'python-install-flags.patch')
-rw-r--r--python-install-flags.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-install-flags.patch b/python-install-flags.patch
new file mode 100644
index 000000000000..9e6e1f0dd45a
--- /dev/null
+++ b/python-install-flags.patch
@@ -0,0 +1,45 @@
+--- capture_freaklabs_zigbee/Makefile.in 2019-10-10 10:49:00.494256269 +0200
++++ capture_freaklabs_zigbee/Makefile.in 2019-10-10 10:52:49.374152190 +0200
+@@ -10,7 +10,7 @@
+ $(PYTHON) ./setup.py bdist
+
+ install:
+- $(PYTHON) ./setup.py install
++ $(PYTHON) ./setup.py install --root="$(DESTDIR)" -O1
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+
+ clean:
+--- capture_sdr_rtl433/Makefile.in 2019-10-10 10:49:00.507590313 +0200
++++ capture_sdr_rtl433/Makefile.in 2019-10-10 10:52:28.069331801 +0200
+@@ -11,7 +11,7 @@
+ $(PYTHON) ./setup.py bdist
+
+ install:
+- $(PYTHON) ./setup.py install
++ $(PYTHON) ./setup.py install --root="$(DESTDIR)" -O1
+
+ clean:
+ @-$(PYTHON) ./setup.py clean
+--- capture_sdr_rtladsb/Makefile.in 2019-10-10 10:49:00.510923825 +0200
++++ capture_sdr_rtladsb/Makefile.in 2019-10-10 10:52:32.542260533 +0200
+@@ -11,7 +11,7 @@
+ $(PYTHON) ./setup.py bdist
+
+ install:
+- $(PYTHON) ./setup.py install
++ $(PYTHON) ./setup.py install --root="$(DESTDIR)" -O1
+ # These are now part of the setup.py install
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) aircraft_db.csv $(ETC)/kismet_aircraft_db.csv
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+--- capture_sdr_rtlamr/Makefile.in 2019-10-10 10:49:00.514257335 +0200
++++ capture_sdr_rtlamr/Makefile.in 2019-10-10 10:52:35.978622527 +0200
+@@ -11,7 +11,7 @@
+ $(PYTHON) ./setup.py bdist
+
+ install:
+- $(PYTHON) ./setup.py install
++ $(PYTHON) ./setup.py install --root="$(DESTDIR)" -O1
+
+ protobuf:
+ $(PROTOCBIN) -I ../protobuf_definitions --python_out=./KismetCaptureRtlamr ../protobuf_definitions/*.proto
+