summarylogtreecommitdiffstats
path: root/python.patch
diff options
context:
space:
mode:
authorbartus2020-05-30 22:34:16 +0200
committerbartus2020-05-30 22:35:25 +0200
commit028aadeb8a39e5241e5c41650137551936a743c8 (patch)
treec558ad932e2088f37bc9344380eaeb121c1fc5c6 /python.patch
parenta62ae9a036c2af04d338d614c1b889320fa0a221 (diff)
downloadaur-028aadeb8a39e5241e5c41650137551936a743c8.tar.gz
Update python.patch
Diffstat (limited to 'python.patch')
-rw-r--r--python.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/python.patch b/python.patch
index 78fec656b917..ee6a94da8aa7 100644
--- a/python.patch
+++ b/python.patch
@@ -21,9 +21,9 @@ index be614b8e8..94918929e 100644
add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
--TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
\ No newline at end of file
-+TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
index 194104caf..241dbd5f2 100644
--- a/samples/luxcoredemo/CMakeLists.txt
@@ -42,19 +42,19 @@ index 3acb27bfa..b52d3ec81 100644
add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
--TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
index c8b23001b..607f92b6a 100644
--- a/samples/luxcoreui/CMakeLists.txt
+++ b/samples/luxcoreui/CMakeLists.txt
-@@ -90,5 +90,6 @@ TARGET_LINK_LIBRARIES(luxcoreui
+@@ -89,4 +92,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
+ ${LUXCORE_LIBRARY}
${OPENGL_LIBRARIES}
${GTK3_LIBRARIES}
- ${Boost_LIBRARIES}
-+ ${PYTHON_LIBRARIES}
- ${OPENCL_LIBRARIES}
- ${CUDA_ALL_LIBRARIES})
+- ${Boost_LIBRARIES})
++ ${Boost_LIBRARIES}
++ ${PYTHON_LIBRARIES})
diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
index edd6e6762..1875ee5cf 100644
--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt